Board index » off-topic » Save Fails Using vcsync

Save Fails Using vcsync


2003-11-10 11:37:52 PM
off-topic11
When vcsync is activated, and Visual Studio (6.0 Version e) is
running, Saving code files sometimes (often) fails, resulting in a file
like MyFile.000 instead of the intended MyFile.cpp. I run XP.
This happens regardless of whether the same file is actually opened
in Visual Studio. It happens often enough to be a big pain. I did some
exploring, and I suspect that visual studio has the file temporarily
opened, at the moment CW is trying to save it.
I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
the problem seems worse.
Has anyone else seen this? Any Ideas would be appreciated. I love CW
otherwise.
Thanx In Advance,
Jake
 
 

Re:Save Fails Using vcsync

Quote
I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
the problem seems worse.
Did you apply the 7.5.3 patch to your version of 7.5? (7.5 has a number of
problems that are fixed with the patch.) You can tell the version from the
lower left coroner of the About box.
I'm using 7.5.3 and Visual Studio .NET 2003 under Windows XP Pro SP-1 with
all Hotfixes and do not have this problem.
You could try disabling all the DLLs you have loaded (remove the LibPreLoad
statements in cwright.ini and reload). See if you have the same problem.
If it "goes away" start adding them back until the problem occurs again.
--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
"Jake" < XXXX@XXXXX.COM >wrote in message
Quote
When vcsync is activated, and Visual Studio (6.0 Version e) is
running, Saving code files sometimes (often) fails, resulting in a file
like MyFile.000 instead of the intended MyFile.cpp. I run XP.
This happens regardless of whether the same file is actually opened
in Visual Studio. It happens often enough to be a big pain. I did some
exploring, and I suspect that visual studio has the file temporarily
opened, at the moment CW is trying to save it.

I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
the problem seems worse.

Has anyone else seen this? Any Ideas would be appreciated. I love CW
otherwise.

Thanx In Advance,
Jake

 

Re:Save Fails Using vcsync

Thanx Thom, but it does not fix the problem. I am using 7.5.03 (I
assume that is the same as 7.5.3). The only dll's I was loading was
"cwsync.dll" and the CodeMeeting. I removed the Code Meeting, and the
problem persists. I had already established that without cwsync, I do
not have the problem, but I need cwsync to work efficiently.
Any other Ideas?
Thanx,
Jake.
Thom Little wrote:
Quote
>I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
>the problem seems worse.


Did you apply the 7.5.3 patch to your version of 7.5? (7.5 has a number of
problems that are fixed with the patch.) You can tell the version from the
lower left coroner of the About box.

I'm using 7.5.3 and Visual Studio .NET 2003 under Windows XP Pro SP-1 with
all Hotfixes and do not have this problem.

You could try disabling all the DLLs you have loaded (remove the LibPreLoad
statements in cwright.ini and reload). See if you have the same problem.
If it "goes away" start adding them back until the problem occurs again.

 

{smallsort}

Re:Save Fails Using vcsync

Yes, this happens to me all the time, with CW 6.6b and VC 6.0 SP4
(?). Sometimes too I get a message from VC that it can't save the open
file because another program has the file open. It is clear to me that these
messages are two sides of the same coin: that CW and VC both are
interested in finding out when the file has changed, and when it changes to
reload the file or at least read directory info.
When it happens in CW I just select File/Save As and save it with the correct
name, and usually the problem is corrected. But it's a pain because I like to
save compulsively after every few lines of code.
Josh
"Jake" < XXXX@XXXXX.COM >wrote in message news: XXXX@XXXXX.COM ...
Quote
When vcsync is activated, and Visual Studio (6.0 Version e) is
running, Saving code files sometimes (often) fails, resulting in a file
like MyFile.000 instead of the intended MyFile.cpp. I run XP.
This happens regardless of whether the same file is actually opened
in Visual Studio. It happens often enough to be a big pain. I did some
exploring, and I suspect that visual studio has the file temporarily
opened, at the moment CW is trying to save it.

I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
the problem seems worse.

Has anyone else seen this? Any Ideas would be appreciated. I love CW
otherwise.

Thanx In Advance,
Jake

 

Re:Save Fails Using vcsync

I have all three options selected in VCSync (this may be useless
information).
You might try a "{*word*269}" CodeWright:
Close the Project Space.
Close CodeWright.
Move cwright.ini out of the CodeWright root to a safe place (like the
desktop).
Move cwright.mac out of the CodeWright root to a safe place.
Copy cwright.i75 from the defaults subdirectory to the CodeWright root.
Rename cwright.i75 to cwright.ini.
Copy cwright.mac from the defaults subdirectory to the CodeWright root.
Enable the VCSync DLL
Run the tests.
Copy cwright.ini from the safe place to the CodeWright root.
Copy cwright.mac from the safe place to the CodeWright root.
Load CodeWright.
Open the Project Space.
I just solved an "annoying" problem on my system by rebuilding a
contaminated Project Space after going though a similar diagnostic
procedure.
--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
"Jake" < XXXX@XXXXX.COM >wrote in message
Quote
Thanx Thom, but it does not fix the problem. I am using 7.5.03 (I
assume that is the same as 7.5.3). The only dll's I was loading was
"cwsync.dll" and the CodeMeeting. I removed the Code Meeting, and the
problem persists. I had already established that without cwsync, I do
not have the problem, but I need cwsync to work efficiently.

Any other Ideas?

Thanx,
Jake.

Thom Little wrote:
>>I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
>>the problem seems worse.
>
>
>Did you apply the 7.5.3 patch to your version of 7.5? (7.5 has a number
of
>problems that are fixed with the patch.) You can tell the version from
the
>lower left coroner of the About box.
>
>I'm using 7.5.3 and Visual Studio .NET 2003 under Windows XP Pro SP-1
with
>all Hotfixes and do not have this problem.
>
>You could try disabling all the DLLs you have loaded (remove the
LibPreLoad
>statements in cwright.ini and reload). See if you have the same
problem.
>If it "goes away" start adding them back until the problem occurs again.
>

 

Re:Save Fails Using vcsync

JayWay,
I am glad (sorry?) to hear that I am not alone in this problem. I too
compulsively save ... learned from years of loosing data to power
outages and system crashes, so it is more than a small problem,
especially since it seems to have gotten worse recently.
Please let me know if you ever find a solution.
Thanx,
Jake.
JayWay wrote:
Quote
Yes, this happens to me all the time, with CW 6.6b and VC 6.0 SP4
(?). Sometimes too I get a message from VC that it can't save the open
file because another program has the file open. It is clear to me that these
messages are two sides of the same coin: that CW and VC both are
interested in finding out when the file has changed, and when it changes to
reload the file or at least read directory info.

When it happens in CW I just select File/Save As and save it with the correct
name, and usually the problem is corrected. But it's a pain because I like to
save compulsively after every few lines of code.

Josh

"Jake" < XXXX@XXXXX.COM >wrote in message news: XXXX@XXXXX.COM ...

>When vcsync is activated, and Visual Studio (6.0 Version e) is
>running, Saving code files sometimes (often) fails, resulting in a file
>like MyFile.000 instead of the intended MyFile.cpp. I run XP.
>This happens regardless of whether the same file is actually opened
>in Visual Studio. It happens often enough to be a big pain. I did some
>exploring, and I suspect that visual studio has the file temporarily
>opened, at the moment CW is trying to save it.
>
>I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
>the problem seems worse.
>
>Has anyone else seen this? Any Ideas would be appreciated. I love CW
>otherwise.
>
>Thanx In Advance,
>Jake
>



 

Re:Save Fails Using vcsync

On Mon, 10 Nov 2003 13:12:00 -0500, Jake
< XXXX@XXXXX.COM >wrote:
Quote
JayWay,

I am glad (sorry?) to hear that I am not alone in this problem. I too
compulsively save ... learned from years of loosing data to power
outages and system crashes, so it is more than a small problem,
especially since it seems to have gotten worse recently.

Please let me know if you ever find a solution.
Perhaps you could disable "detect when file is changed outside the
environment" in Visual Studio options ->environment ->documents.
Graeme
 

Re:Save Fails Using vcsync

If you tried the "{*word*269} CodeWright" test under 7.5.3 and got the same
result then you could report it to Borland as a BUG.
--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
"Jake" < XXXX@XXXXX.COM >wrote in message
Quote
Thanx Thom, but it does not fix the problem. I am using 7.5.03 (I
assume that is the same as 7.5.3). The only dll's I was loading was
"cwsync.dll" and the CodeMeeting. I removed the Code Meeting, and the
problem persists. I had already established that without cwsync, I do
not have the problem, but I need cwsync to work efficiently.

Any other Ideas?

Thanx,
Jake.

Thom Little wrote:
>>I had a similar problem in CW6.0, so I upgraded to 7.5. Unfortunately,
>>the problem seems worse.
>
>
>Did you apply the 7.5.3 patch to your version of 7.5? (7.5 has a number
of
>problems that are fixed with the patch.) You can tell the version from
the
>lower left coroner of the About box.
>
>I'm using 7.5.3 and Visual Studio .NET 2003 under Windows XP Pro SP-1
with
>all Hotfixes and do not have this problem.
>
>You could try disabling all the DLLs you have loaded (remove the
LibPreLoad
>statements in cwright.ini and reload). See if you have the same
problem.
>If it "goes away" start adding them back until the problem occurs again.
>

 

Re:Save Fails Using vcsync

"{*word*269} CodeWright"?
Thom Little wrote:
Quote
If you tried the "{*word*269} CodeWright" test under 7.5.3 and got the same
result then you could report it to Borland as a BUG.

 

Re:Save Fails Using vcsync

Graeme,
I could not find options ->environment ->documents - I did mention in
my original post that I am still on VisualStudio 6.0. There is an
option in VS6.0 to "Automatically reload externally modified files",
which I have had off for ages.
Thanx Though,
Jake
Graeme Prentice wrote:
Quote
On Mon, 10 Nov 2003 13:12:00 -0500, Jake
< XXXX@XXXXX.COM >wrote:


>JayWay,
>
>I am glad (sorry?) to hear that I am not alone in this problem. I too
>compulsively save ... learned from years of loosing data to power
>outages and system crashes, so it is more than a small problem,
>especially since it seems to have gotten worse recently.
>
>Please let me know if you ever find a solution.


Perhaps you could disable "detect when file is changed outside the
environment" in Visual Studio options ->environment ->documents.

Graeme
 

Re:Save Fails Using vcsync

It refers to the previous message I sent to you about running with the
distributed cwright.ini, cwright.mac, and no Project Space.
--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
"Jake" < XXXX@XXXXX.COM >wrote in message
Quote
"{*word*269} CodeWright"?
 

Re:Save Fails Using vcsync

Perhaps ...
Tools | Options... | Editor | Automatically reload externally modified files
... ?
--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
"Graeme Prentice" < XXXX@XXXXX.COM >wrote in message
Quote
On Mon, 10 Nov 2003 13:12:00 -0500, Jake
< XXXX@XXXXX.COM >wrote:

>JayWay,
>
>I am glad (sorry?) to hear that I am not alone in this problem. I too
>compulsively save ... learned from years of loosing data to power
>outages and system crashes, so it is more than a small problem,
>especially since it seems to have gotten worse recently.
>
>Please let me know if you ever find a solution.

Perhaps you could disable "detect when file is changed outside the
environment" in Visual Studio options ->environment ->documents.

Graeme
 

Re:Save Fails Using vcsync

Thom,
Already tried it.
Thanx though.
Thom Little wrote:
Quote
Perhaps ...

Tools | Options... | Editor | Automatically reload externally modified files

... ?

 

Re:Save Fails Using vcsync

On Tue, 11 Nov 2003 08:57:38 -0500, Jake
< XXXX@XXXXX.COM >wrote:
Quote
Graeme,

I could not find options ->environment ->documents - I did mention in
my original post that I am still on VisualStudio 6.0. There is an
option in VS6.0 to "Automatically reload externally modified files",
which I have had off for ages.

I don't have that version. What about under the tools options general
tab - I guess you've looked already but I found a message on google
indicating it might be there.
Graeme
 

Re:Save Fails Using vcsync

On Mon, 10 Nov 2003 10:37:52 -0500, Jake < XXXX@XXXXX.COM >wrote:
Quote
When vcsync is activated, and Visual Studio (6.0 Version e) is
running, Saving code files sometimes (often) fails, resulting in a file
like MyFile.000 instead of the intended MyFile.cpp. I run XP.
This happens regardless of whether the same file is actually opened
in Visual Studio. It happens often enough to be a big pain. I did some
exploring, and I suspect that visual studio has the file temporarily
opened, at the moment CW is trying to save it.

Just to add another data point....
At the moment I am using cw 7.5.3 on Win 2003 Server with VS.net via
vcsync. In these projects I have the following settings with mostly
no troubles.
- auto-save on loss of focus
- allow save past last write
- suppress reload prompt
- auto-reload changed files
Check to see if XP is running any auto-indexing services.
If so, you might want to turn those off.
---------+---------+---------+---------+---------+---------+---------+
Joseph Kiernan
Seattle, WA