Board index » delphi » Help with stored procedure for SQL 7.0

Help with stored procedure for SQL 7.0

I am using Delphi 3.0 Professional with BDE 5.01.

The following code does not execute in SQL 7.0

   exec spamCPSSaveShelfProduct 'TRANSPORTATION',  , 0
                                                 ^^

the problem is that Delphi sends a string parameter which is null as
nothing. It does not include the tick marks ('). The corrected version is
below.

   exec spamCPSSaveShelfProduct 'TRANSPORTATION', '' , 0
                                                  ^^

Does anyone know how I can get Delphi to send the second version instead of
the first? Or can I change a property of SQL 7.0 to allow this to be valid?

Any help is greatly appreciated.

Abel
a...@coyotedesigns.com

 

Re:Help with stored procedure for SQL 7.0


Have you tried '''' for the null string? That is four single quotes,
no spaces.
HTH,
Dan

On Thu, 3 Jun 1999 00:21:45 -0500, "Coyote Designs"

Quote
<coyotedesi...@goplay.com> wrote:
>I am using Delphi 3.0 Professional with BDE 5.01.

>The following code does not execute in SQL 7.0

>   exec spamCPSSaveShelfProduct 'TRANSPORTATION',  , 0
>                                                 ^^

>the problem is that Delphi sends a string parameter which is null as
>nothing. It does not include the tick marks ('). The corrected version is
>below.

>   exec spamCPSSaveShelfProduct 'TRANSPORTATION', '' , 0
>                                                  ^^

>Does anyone know how I can get Delphi to send the second version instead of
>the first? Or can I change a property of SQL 7.0 to allow this to be valid?

>Any help is greatly appreciated.

>Abel
>a...@coyotedesigns.com

--
Dan Brennand
CMDC systems, inc.
Configuration Management and Document Control: Consulting, Software,
and the only comprehesive textbook on this subject.
visit us at www.cmdcsystems.com
[Remove the SPAM from my e-mail address]

Other Threads