Board index » delphi » problem registering automation server

problem registering automation server

Hello,

does anybody know if it is absolutely necessary
for an out-of-process server to base such an
application on TApplication? (I use Delphi 4 Prof.)

I created a very simple application just containing
the lines

program SimpleCOM;
uses windows;
begin
end.

(The reason why I tried this simple application is that
I need an out-of-process-server but no graphic
interface. So I thought this could be a solution to
get rid of unnecessary overhead.)

There is no problem to generate all files using
File/New/ActiveX/Automation Object and so on.

But if the EXE file is run, it doesn't register
itself. Any suggestions?

Regards,
U. Schoth

--
Dr.-Ing. U. Schoth
Project manager R&D
KROHNE Messtechnik, Ludwig-Krohne-Strasse 5,
47008 Duisburg, Germany

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

 

Re:problem registering automation server


Quote
USchoth <usch...@krohne.de> writes:
> I created a very simple application just containing
> the lines

> program SimpleCOM;
> uses windows;
> begin
> end.

> (The reason why I tried this simple application is that
> I need an out-of-process-server but no graphic
> interface. So I thought this could be a solution to
> get rid of unnecessary overhead.)

> But if the EXE file is run, it doesn't register
> itself. Any suggestions?

Most likely TApplication is doing this. You can do this yourself directly, most
probably. Just hunt around the COM libraries.
--
Cheers,                                        The Rhythm is around me,
                                               The Rhythm has control.
Ray Blaak                                      The Rhythm is inside me,
bl...@infomatch.com                            The Rhythm has my soul.

Other Threads