Board index » delphi » TIBStoredProc doesn't find parameters

TIBStoredProc doesn't find parameters

Hello,

I'm trying to use TIBStoredProc with Delphi5 and Interbase OpenSource, to
execute a stored procedure. This stored procedure has an input parameter,
but when i try to use it with TIBStoredProc, i can't access the input
parameter, it sends a message telling that it doesn't exist.

My code for the stored procedure is like this:

CREATE PROCEDURE "EliminaEntrada" (
    DATAENT DATE)
AS
BEGIN
  DELETE FROM ROLOS WHERE DATAENTRADA=:dataent;
END

I'm using the Interbase server in linux.
Can someone give me a hint why this isn't working.
Thanks in advance,

Paulo Cruz

 

Re:TIBStoredProc doesn't find parameters


What version of IBX?  Early versions required you call prepare before accessing
the parameters.

Quote
i...@izn.pt wrote:

> Hello,

> I'm trying to use TIBStoredProc with Delphi5 and Interbase OpenSource, to
> execute a stored procedure. This stored procedure has an input parameter,
> but when i try to use it with TIBStoredProc, i can't access the input
> parameter, it sends a message telling that it doesn't exist.

> My code for the stored procedure is like this:

> CREATE PROCEDURE "EliminaEntrada" (
>     DATAENT DATE)
> AS
> BEGIN
>   DELETE FROM ROLOS WHERE DATAENTRADA=:dataent;
> END

> I'm using the Interbase server in linux.
> Can someone give me a hint why this isn't working.
> Thanks in advance,

> Paulo Cruz

--
Jeff Overcash (TeamB)
      (Please do not email me directly unless  asked. Thank You)
This sad little lizard told me that he was a brontosaurus on his mother's
side.  I did not laugh; people who boast of ancestry often have little else
to sustain them.  Humoring them costs nothing and adds to happiness in
a world in which happiness is in short supply.   (RAH)

Re:TIBStoredProc doesn't find parameters


Thanks, it was the Prepare.

Paulo Cruz

Quote
>>>>>>>>>>>>>>>>>> Mensagem anterior <<<<<<<<<<<<<<<<<<

No dia 19-06-2002, 13:22:59, "Jeff Overcash (TeamB)"
<jeffoverc...@mindspring.com> escreveu o seguinte sobre o tema Re:
TIBStoredProc doesn't find parameters:

Quote
> What version of IBX?  Early versions required you call prepare before
accessing
> the parameters.
> i...@izn.pt wrote:

> > Hello,

> > I'm trying to use TIBStoredProc with Delphi5 and Interbase OpenSource, to
> > execute a stored procedure. This stored procedure has an input parameter,
> > but when i try to use it with TIBStoredProc, i can't access the input
> > parameter, it sends a message telling that it doesn't exist.

> > My code for the stored procedure is like this:

> > CREATE PROCEDURE "EliminaEntrada" (
> >     DATAENT DATE)
> > AS
> > BEGIN
> >   DELETE FROM ROLOS WHERE DATAENTRADA=:dataent;
> > END

> > I'm using the Interbase server in linux.
> > Can someone give me a hint why this isn't working.
> > Thanks in advance,

> > Paulo Cruz
> --
> Jeff Overcash (TeamB)
>       (Please do not email me directly unless  asked. Thank You)
> This sad little lizard told me that he was a brontosaurus on his mother's
> side.  I did not laugh; people who boast of ancestry often have little
else
> to sustain them.  Humoring them costs nothing and adds to happiness in
> a world in which happiness is in short supply.   (RAH)

Re:TIBStoredProc doesn't find parameters


Quote
i...@izn.pt wrote:

> Thanks, it was the Prepare.

Then I suggest you get on the latest version.  There are many bug fixes you are
missing.

--
Jeff Overcash (TeamB)
      (Please do not email me directly unless  asked. Thank You)
This sad little lizard told me that he was a brontosaurus on his mother's
side.  I did not laugh; people who boast of ancestry often have little else
to sustain them.  Humoring them costs nothing and adds to happiness in
a world in which happiness is in short supply.   (RAH)

Other Threads