Board index » delphi » ODBC (help) : bde 4.51, odbc 3.5, D3, Sql 6.5

ODBC (help) : bde 4.51, odbc 3.5, D3, Sql 6.5

Please help,

Configuration :
    BD 4.51,
    ODBC 3.5
    Delphi 3 C/S
    SQL Server 6.5 ( sp 4)
    NT Workstation 4

    Until last week i worked with ODBC 2.6, sql link 4.0, Sql 6.5 (sp 2)
with no problem.
   After I started to get a "operation not applicable", i installed the
above versions.

    The Sql 6.5 Enterprise Manager works fine, including Query Tools,
but he delphi program started to connect with no query or table
functioning, even the Dbexplor connect to sql throw ODBC but when I
click at the [+] Tables   the utilization of the CPU raise to 100% and
no table is displayed.

  I tried to connect to Interbase DataBase throw the Dbexplor and it
works fine.

 I tried to install the old ODBC -> no success.

What's going on here ?????

Is it a problem of the new ODBC 3.5 version ??

Did Inprise (borland) decided that MS Sql Server it not good for people
!!, or did Microsoft decided the same.

   last week i have a series problem with my computer,

 

Re:ODBC (help) : bde 4.51, odbc 3.5, D3, Sql 6.5


We're running a similar setup except clients are Win95 without any flaws.

Using tcp/ip sockets as protocol. Svr has to be setup for it using port
1433. Client also must be setup.
--
Remove NOSPAM. from email

Rabeh Mansour <khkha...@netvision.net.il> wrote in article
<35742F7A.8C67F...@netvision.net.il>...

Quote
> Please help,

> Configuration :
>     BD 4.51,
>     ODBC 3.5
>     Delphi 3 C/S
>     SQL Server 6.5 ( sp 4)
>     NT Workstation 4

>     Until last week i worked with ODBC 2.6, sql link 4.0, Sql 6.5 (sp 2)
> with no problem.
>    After I started to get a "operation not applicable", i installed the
> above versions.

>     The Sql 6.5 Enterprise Manager works fine, including Query Tools,
> but he delphi program started to connect with no query or table
> functioning, even the Dbexplor connect to sql throw ODBC but when I
> click at the [+] Tables   the utilization of the CPU raise to 100% and
> no table is displayed.

>   I tried to connect to Interbase DataBase throw the Dbexplor and it
> works fine.

>  I tried to install the old ODBC -> no success.

> What's going on here ?????

> Is it a problem of the new ODBC 3.5 version ??

> Did Inprise (borland) decided that MS Sql Server it not good for people
> !!, or did Microsoft decided the same.

>    last week i have a series problem with my computer,

Re:ODBC (help) : bde 4.51, odbc 3.5, D3, Sql 6.5


Rabeh,

I have almost the same identical setup as you, including the problems,
except that NT Workstation 4 is NT Server 4 on my setup. I have posted
questions on this topic and have gotten no valid responses.

Further info: The same problem existed with the BDE 3.51, 4.0, 4.01, and
4.51. This configuration works fine in Windows 95, but doesn't in Windows
NT.  What's up?

I am about to be in deep doo-doo if I can't solve this problem also...

I cannot believe that more people have not run into this problem, or that
Borland doesn't have some sort of whitepaper on it, but there doesn't seem
to be anything out there.

I am adding my voice to Rabeh's question: Does anyone out there know
anything?

-Tom

Other Threads