Board index » delphi » problems installing BDE 4.51 using Installshield 1.11a

problems installing BDE 4.51 using Installshield 1.11a

Hello
I am depolying my app written in Delphi 3.0 and using BDE4.51
setup program is created with InstallShiled v.1.11a that comes with
Delphi 3.0
Most of the workstations where app executable and full BDE is
installed are OK
However on some PCs BDE did not install properly
I mean setup is not reporting any errors, but after setup is finished
Delphi exe will not run, it just hangs. Same is true for bdeadmin.exe.
It just
hangs and only chance is Ctrl-Alt-Delete
Any help in debugging problem will be much appreciated

best regards
Rumen

 

Re:problems installing BDE 4.51 using Installshield 1.11a


Quote
>However on some PCs BDE did not install properly
>I mean setup is not reporting any errors, but after setup is finished
>Delphi exe will not run, it just hangs. Same is true for bdeadmin.exe.
>It just
>hangs and only chance is Ctrl-Alt-Delete
>Any help in debugging problem will be much appreciated

You need to first check if the correct BDE files got installed.
If the BDE files where correctly installed then try deleting the BDE config
file.   Run BDEAdmin it will allow you to save the configuration as a new BDE
config file.
If you still can't start BDEAdmin after deleting the BDE config file then you
will have to manually clean out the registry of all references to BDE.  I have
seen this problem come up in some machines that have had many different versions
of BDE installed.

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Re:problems installing BDE 4.51 using Installshield 1.11a


On Thu, 24 Dec 1998 15:56:13 GMT, rli...@mbox.digsys.bg (Rumen Lilov)
wrote:

Quote
>However on some PCs BDE did not install properly
>I mean setup is not reporting any errors, but after setup is finished
>Delphi exe will not run, it just hangs. Same is true for bdeadmin.exe.

Check what the difference is between the two machines (the one that worked,
and the one that doesn't). Either the files were not installed correctly,
or the registry keys wer not added correctly.

Stefan
InstallShield Software Corp.

Other Threads