Board index » delphi » database paradox having local and network tables....

database paradox having local and network tables....

Not sure if this is the right newsgroup for this question...but it has a few
parts...

I have application that currently I have been using on multiple
stations....I have 4 separate exe that run separate functions....

In the BDE......I have set the path for the data and pointed the pdoxnet
file in to c:\myapp\pdoxnet.....
All has been working fine...each app has separate priv directory...but all
point to the same pdoxnet...

What I need to do now as I am now going back through my exe to make my
database apps....share some tables...and keep sometables local to the
exe.......I need to do the following...

A). I need to set up local tables and network tables...so some of the tables
are kept locally and others on a shared directory....

What I have seen is two approaches ...there may be more ......

1. use an ini file to point to the path you need

2. use registry settings......

I have not done neither....so I am very green at these......

If anyone has some insight in to either of these approaches or another it
would be appreciated...

Thank you ,

Alex

 

Re:database paradox having local and network tables....


Alex,

It sounds as though we both have roughly the same problem. See
"Local/Sever Data" message. I have outlined there what I propose to try
and asked for comments. It may give you a start.

Bob
--
Using Virtual Access
http://www.vamail.com

Re:database paradox having local and network tables....


One good solution for local tables is to put them in the user's private
directory. This will not work if the user needs to run multiple applications
at the same time and they all need to access the same set of local tables.

If each user needs to have his/her own settings using the registry is
probably a good solution. If you are going to put the EXE on the file server
and can use one set of settings for all users then an INI file is the
easiest.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Other Threads