Board index » delphi » Delphi v.1 Making EXE run

Delphi v.1 Making EXE run

I have an application that I have made and it uses two databases.
When I go to build all and then copy it to a disk with the *.DB files
and try to run it on a computer without Delphi installed Windows says
something along the lines of BDE not found or something like that,
what do I need to include with the EXE to make it function correctly?

Thanks in advance...

                                        DarkFyre

 

Re:Delphi v.1 Making EXE run


You need to install the distribution of dbe which should be in your
Delphi package.
Otherwise you cannot connect to any database.

Quote
fvkim...@ucfv.bc.ca (DarkFyre) wrote:
>I have an application that I have made and it uses two databases.
>When I go to build all and then copy it to a disk with the *.DB files
>and try to run it on a computer without Delphi installed Windows says
>something along the lines of BDE not found or something like that,
>what do I need to include with the EXE to make it function correctly?
>Thanks in advance...
>                                    DarkFyre

Re:Delphi v.1 Making EXE run


Quote
fvkim...@ucfv.bc.ca (DarkFyre) writes: > I have an application that I have made and it uses two databases.
> When I go to build all and then copy it to a disk with the *.DB files
> and try to run it on a computer without Delphi installed Windows says
> something along the lines of BDE not found or something like that,
> what do I need to include with the EXE to make it function correctly?

> Thanks in advance...

>                                    DarkFyre

There is a number of DLL which you have to use whenever you use
Database components in your applications. Please read the DEPLOY.TXT
file in the DELPHI directory.  If you used some custom VBX, you need
to copy them as well.  I think the CD also contains a directory which
contain all the files required for specific database.  Check it out.

Re:Delphi v.1 Making EXE run


Quote
fvkim...@ucfv.bc.ca (DarkFyre) wrote:

> I have an application that I have made and it uses two databases.
> When I go to build all and then copy it to a disk with the *.DB files
> and try to run it on a computer without Delphi installed Windows says
> something along the lines of BDE not found or something like that,
> what do I need to include with the EXE to make it function correctly?

> Thanks in advance...

>                                    DarkFyre

You have to also install the Delphi BDE on the target computer.

Phil

Other Threads