Board index » delphi » Delphi 2007 sometimes on a go-slow

D2007 sometimes on a go-slow


2007-04-04 04:01:31 PM
delphi106
I have a large project with some large files. Quite often if I change forms
and then instantly try and initiate a "Search" I have to wait maybe 15
seconds while Delphi has a think before it displays the Find dialog and then
maybe another 15 seconds while it does the search.
Also when I initiate a Build, it can take about 15 seconds before it even
starts.
In D2006 I remember turning off all that Together stuff in the Registry
(Known IDE Packages - TGIDE100.BPL). Do I have to do something simplar
again, or is this a different issue.
FWIW - this computer is 2.5Ghz with 1.5GB RAM
Any help much appreciated
Graham
 
 

Re:D2007 sometimes on a go-slow

On Apr 4, 1:01 am, "Graham Powell" <XXXX@XXXXX.COM>writes:
Quote
I have a large project with some large files. Quite often if I change forms
and then instantly try and initiate a "Search" I have to wait maybe 15
seconds while Delphi has a think before it displays the Find dialog and then
maybe another 15 seconds while it does the search.
Also when I initiate a Build, it can take about 15 seconds before it even
starts.

In D2006 I remember turning off all that Together stuff in the Registry
(Known IDE Packages - TGIDE100.BPL). Do I have to do something simplar
again, or is this a different issue.

FWIW - this computer is 2.5Ghz with 1.5GB RAM

Any help much appreciated
Graham
Graham:
With older versions of Delphi I experienced a giant slow down and
could not figure out why. It turns out that in my project options I
had some invalid directories listed in the search path and this caused
Delphi to attempt to search them and ultimately timeout, but no error
message was presented. Once I deleted the invalid directories in the
search path, Delphi was back to top speed. I can not confirm this is
your problem with Delphi 2007, but it is something you can check out.
Cheers,
Peter Blair
Titan Developer
Reggatta Systems, Inc.
www.reggatta.com
 

Re:D2007 sometimes on a go-slow

Unfortunately not the case here. I have 24 entries in the Library path and
all are valid directories. The Browsing path also contains valid
directrories.
Graham
<XXXX@XXXXX.COM>writes
Quote
On Apr 4, 1:01 am, "Graham Powell" <XXXX@XXXXX.COM>writes:
>I have a large project with some large files. Quite often if I change
>forms
>and then instantly try and initiate a "Search" I have to wait maybe 15
>seconds while Delphi has a think before it displays the Find dialog and
>then
>maybe another 15 seconds while it does the search.
>Also when I initiate a Build, it can take about 15 seconds before it even
>starts.
>
>In D2006 I remember turning off all that Together stuff in the Registry
>(Known IDE Packages - TGIDE100.BPL). Do I have to do something simplar
>again, or is this a different issue.
>
>FWIW - this computer is 2.5Ghz with 1.5GB RAM
>
>Any help much appreciated
>Graham

Graham:

With older versions of Delphi I experienced a giant slow down and
could not figure out why. It turns out that in my project options I
had some invalid directories listed in the search path and this caused
Delphi to attempt to search them and ultimately timeout, but no error
message was presented. Once I deleted the invalid directories in the
search path, Delphi was back to top speed. I can not confirm this is
your problem with Delphi 2007, but it is something you can check out.

Cheers,

Peter Blair
Titan Developer
Reggatta Systems, Inc.
www.reggatta.com


 

Re:D2007 sometimes on a go-slow

Graham Powell writes:
Quote
I have a large project with some large files. Quite often if I change
forms and then instantly try and initiate a "Search" I have to wait
maybe 15 seconds while Delphi has a think before it displays the Find
dialog and then maybe another 15 seconds while it does the search.
Also when I initiate a Build, it can take about 15 seconds before it
even starts.
Non-existing (network-) folders in any of the search paths can give
this effect in older versions of Delphi.
--
Anders Isaksson, Sweden
BlockCAD: web.telia.com/~u16122508/proglego.htm
Gallery: web.telia.com/~u16122508/gallery/index.htm
 

Re:D2007 sometimes on a go-slow

It would appear that I had a Package listed but there was no associated .bpl
file. Suddenly Delphi2007 started to report that it couldn't find this file
and so the problem has now been resolved by removing it from the list.
So today everything is good. Still get the occasional blow out with D2007.
Certainly if you hold the keys down and use auto-repeat. Try deleting a
whole bunch of lines by holding down Ctrl+Y. Sometimes you are lucky,
sometimes booom!
Graham
"Anders Isaksson" <i.rather@not>writes
Quote
Graham Powell writes:

>I have a large project with some large files. Quite often if I change
>forms and then instantly try and initiate a "Search" I have to wait
>maybe 15 seconds while Delphi has a think before it displays the Find
>dialog and then maybe another 15 seconds while it does the search.
>Also when I initiate a Build, it can take about 15 seconds before it
>even starts.

Non-existing (network-) folders in any of the search paths can give
this effect in older versions of Delphi.

--
Anders Isaksson, Sweden
BlockCAD: web.telia.com/~u16122508/proglego.htm
Gallery: web.telia.com/~u16122508/gallery/index.htm
 

Re:D2007 sometimes on a go-slow

Graham Powell writes:
Quote
It would appear that I had a Package listed but there was no associated .bpl
file. Suddenly Delphi2007 started to report that it couldn't find this file
and so the problem has now been resolved by removing it from the list.

So today everything is good. Still get the occasional blow out with D2007.
Certainly if you hold the keys down and use auto-repeat. Try deleting a
whole bunch of lines by holding down Ctrl+Y. Sometimes you are lucky,
sometimes booom!
Does it happen a lot to you? Just tried on a couple files for several
times and I was "lucky" all the time! :)
Are you using any 3rd party IDE enhancers? Particularly, any that is for
BDS2006 and not yet recompiled for D2007? (Yeah, I know, it *should* be
non-breaking...)
 

Re:D2007 sometimes on a go-slow

Well today it appears ok. But the original problem has restarted. I am in the
middle of a large unit, do a Ctrl+Home followed by Alt+S and it takes about
15 seconds for the drop-down to appear. If I hop to another unit and Alt+S,
same thing. Alt+R also suffers the same way. The IDE is going off to do
something, but what?
I have now done the same trick as with D2006 in that I have removed
TGIDE100.bpl from the "Known IDE Packages" in the registry. Unfortunately
didn't fix it this time.
Graham
"Fernando Madruga" <XXXX@XXXXX.COM>writes
Quote
Graham Powell writes:
>It would appear that I had a Package listed but there was no associated
>.bpl file. Suddenly Delphi2007 started to report that it couldn't find
>this file and so the problem has now been resolved by removing it from
>the list.
>
>So today everything is good. Still get the occasional blow out with
>D2007. Certainly if you hold the keys down and use auto-repeat. Try
>deleting a whole bunch of lines by holding down Ctrl+Y. Sometimes you are
>lucky, sometimes booom!

Does it happen a lot to you? Just tried on a couple files for several
times and I was "lucky" all the time! :)
Are you using any 3rd party IDE enhancers? Particularly, any that is for
BDS2006 and not yet recompiled for D2007? (Yeah, I know, it *should* be
non-breaking...)
 

Re:D2007 sometimes on a go-slow

Graham Powell writes:
Quote
Well today it appears ok. But the original problem has restarted. I am in the
middle of a large unit, do a Ctrl+Home followed by Alt+S and it takes about
15 seconds for the drop-down to appear. If I hop to another unit and Alt+S,
same thing. Alt+R also suffers the same way. The IDE is going off to do
something, but what?
Does it always happen on the same file? Did you try loading that file
without any project open and see if it happens also?
 

Re:D2007 sometimes on a go-slow

I opened the project and just had the main form open and it appears to be
OK. I did have about 6 or 7 large files open. Maybe Delphi 2007 can not cope with
all this open at once. I have 1.5Gbytes of RAM.
I never had this problem with Delphi 7 and I am sure that with D2006, once I hade
completely disabled anything to do with Together Support it was fine as
well.
Graham
"Fernando Madruga" <XXXX@XXXXX.COM>writes
Quote
Graham Powell writes:
>Well today it appears ok. But the original problem has restarted. I am in
>the middle of a large unit, do a Ctrl+Home followed by Alt+S and it takes
>about 15 seconds for the drop-down to appear. If I hop to another unit
>and Alt+S, same thing. Alt+R also suffers the same way. The IDE is going
>off to do something, but what?

Does it always happen on the same file? Did you try loading that file
without any project open and see if it happens also?
 

Re:D2007 sometimes on a go-slow

Rick,
| In particular, look at the
| threads started by Quentin Correll.
I've filed a QC Reort, Number: 44209.
Unfortuantely, my large project is also proprietary and I cannot
include it for a test case. <sigh>
--
Q
04/12/2007 09:57:57
XanaNews Version 1.17.5.7 [Q's salutation mod]