Board index » delphi » Schema loading when opening a table on D4/BDE 4.51/ORacle 7

Schema loading when opening a table on D4/BDE 4.51/ORacle 7

I remarked that sometimes the schema of the table (columns and indexes)
is loaded when opening it, sometimes it is not.
The parameters ENABLED SCHEMA CACHE is set to False.
So, the performances of my program are strongly affected every time the
schemas are loaded.

Any Ideas ???

 

Re:Schema loading when opening a table on D4/BDE 4.51/ORacle 7


Schemas are cached when an object is created.  If you
close and open an object, the second time it shouldn't
return the Schema.  If your database design is set, then
turn on Enabled Schema Cache.

Quote
Bernard DUCASSE wrote:

> I remarked that sometimes the schema of the table (columns and indexes)
> is loaded when opening it, sometimes it is not.
> The parameters ENABLED SCHEMA CACHE is set to False.
> So, the performances of my program are strongly affected every time the
> schemas are loaded.

> Any Ideas ???

--
Thomas Miller
Delphi Client/Server Certified Developer
BSS Accounting & Distribution Software
BSS Application FrameWork
BSS VCL Pack

http://www.bss-software.com

Re:Schema loading when opening a table on D4/BDE 4.51/ORacle 7


Schema information is not necessary for dead queries (RequestLive = False).

V/R
Russell L. Smith

Quote
Bernard DUCASSE wrote in message <35FE0E5C.DD084...@pharos.fr>...
>I remarked that sometimes the schema of the table (columns and indexes)
>is loaded when opening it, sometimes it is not.

Other Threads