Board index » delphi » SQL Server 7/OLE DB Connection Problem

SQL Server 7/OLE DB Connection Problem

We have the following setup:  SQL Server 7 on one server, the
application exe  and udl file located on another server
that the client machines access to run the program.  The client is
running Win NT 4.0 SP 4 with MDAC 2.1 for client
connectivity and both servers are NT 4 as well.
If I run the provider on the shared server to setup the connection we
are using, (MS OLE DB Provider for SQL
Server), and click on test connection it succeeds.  I get the following
error when trying to run the executable:
(dbnmpntw Specified SQL Server Not Found).  What are we doing wrong?

Thanks

Jeff

 

Re:SQL Server 7/OLE DB Connection Problem


Somehow it can not see the server.

1/ Is the server started.
2/ Look at the client network utility docs, depending on the prototcol and
the port number of your SQL Server, your client may not be trying to connect
the right way.

-Euan

Quote
"Jeff" <j...@firstchoicetechnology.com> wrote in message

news:3ACB3586.FB604A8E@firstchoicetechnology.com...
Quote
> We have the following setup:  SQL Server 7 on one server, the
> application exe  and udl file located on another server
> that the client machines access to run the program.  The client is
> running Win NT 4.0 SP 4 with MDAC 2.1 for client
> connectivity and both servers are NT 4 as well.
> If I run the provider on the shared server to setup the connection we
> are using, (MS OLE DB Provider for SQL
> Server), and click on test connection it succeeds.  I get the following
> error when trying to run the executable:
> (dbnmpntw Specified SQL Server Not Found).  What are we doing wrong?

> Thanks

> Jeff

Other Threads