Board index » delphi » TToolbar wrap problem

TToolbar wrap problem

Hello,

I have just installed the Maint rel update 1 and Maint rel patch 2.  The
problem (as usual) is with the TToolbar.  I have wrappable set to true.
On the toolbar are 8 buttons.  I have the List, Captions, and Autosize
set to true.  In the designmode, wrapping works as planned...only the
last button (in the top row) drops down to form a new row when the form
is resized, and so forth for the remain buttons.  (i.e. as the form size
is reduced, only one button is wrapped at a time.).

But during runtime, the row splits in half, with 4 buttons on top and
four buttons on button.  I did have an event handler for the forms paint
to set Autosize to False and True again, with a Refresh to compensate
for Borland bug in previous version.  I have disabled/removed this
because it seems Borland has fixed the repaint problem...but now it
seems another bug as been reintroduced.

Any ideas?

Thanx

DWK

 

Re:TToolbar wrap problem


Do you have separators in your toolbar? Mine always tries to wrap at a
separator - but I think it does that in both design and runtime. Hmmm...
--
Tim Borman
tbor...@nospam.prophase.com
please reply to this newsgroup
-----------------------------------------------------

Quote
David W. Keefer wrote in message <34A34BA3.C6CEC...@gte.net>...
>Hello,

>I have just installed the Maint rel update 1 and Maint rel patch 2.  The
>problem (as usual) is with the TToolbar.  I have wrappable set to true.
>On the toolbar are 8 buttons.  I have the List, Captions, and Autosize
>set to true.  In the designmode, wrapping works as planned...only the
>last button (in the top row) drops down to form a new row when the form
>is resized, and so forth for the remain buttons.  (i.e. as the form size
>is reduced, only one button is wrapped at a time.).

>But during runtime, the row splits in half, with 4 buttons on top and
>four buttons on button.  I did have an event handler for the forms paint
>to set Autosize to False and True again, with a Refresh to compensate
>for Borland bug in previous version.  I have disabled/removed this
>because it seems Borland has fixed the repaint problem...but now it
>seems another bug as been reintroduced.

>Any ideas?

>Thanx

>DWK

Re:TToolbar wrap problem


No, no separators.  As far as I know, only the last button that will
move off the form should drop down.  It does this during design time but
it splits half and half at run time.  One interesting thing though, when
I build with runtime packages, the runtime works as desired.  I wonder
if some of my packages are obsolete?  Even if they are, it seems the old
packages had the desired behavior.  I could deal with having to manually
refresh.  What these things do now is just plain ugly....

Dave K.

Quote
Tim Borman wrote:
> Do you have separators in your toolbar? Mine always tries to wrap at a

> separator - but I think it does that in both design and runtime.
> Hmmm...
> --
> Tim Borman
> tbor...@nospam.prophase.com
> please reply to this newsgroup

Other Threads