Board index » delphi » A TTable Bug...

A TTable Bug...

OK, I don't know if this is a known one or not, but...

When I try to filter on two fields by AND - ing them together (ie A=1
AND B>2), as per the TTable documentation, the filtering for the
second field doesn't work.

I just got bitten hard by this one.

I'm using D2 and Oracle 7.3

I haven't tried this with non - Oracle tables, so I don't know if it's
a SQL problem or something else...

BTW, I ran SQL monitor during these TTable operations, and the TTable
object did not appear to be preparing the SQL correctly.

Any ideas? Or am I missing something?

TTFN
Mike
J. M. Blevins CACI/IMSS, Inc. I work for cheap, I drink a lot, and I don't sleep.
In other words, I'm a model programmer.

 

Re:A TTable Bug...


J. M. Blevins <eaeol...@crosslink.net> Wrote
<3312fa8f.304...@news.crosslink.net>...

Quote
> OK, I don't know if this is a known one or not, but...

> When I try to filter on two fields by AND - ing them together (ie A=1
> AND B>2), as per the TTable documentation, the filtering for the
> second field doesn't work.

Try
(a=1) and (b>2)

Re:A TTable Bug...


On 26 Feb 97 21:47:19 GMT, "Jacob P.H.Sandin" <ja...@sverige.net>
wrote:

Quote

>J. M. Blevins <eaeol...@crosslink.net> Wrote
><3312fa8f.304...@news.crosslink.net>...
>> OK, I don't know if this is a known one or not, but...

>> When I try to filter on two fields by AND - ing them together (ie A=1
>> AND B>2), as per the TTable documentation, the filtering for the
>> second field doesn't work.
>Try
>(a=1) and (b>2)

I did try that, actually, and that's what puzzles me. I've tried every
parenthetical expression I can think of. Anybody else see this, or am
I a flake?

TTFN
Mike

J. M. Blevins CACI/IMSS, Inc. I work for cheap, I drink a lot, and I don't sleep.
In other words, I'm a model programmer.

Re:A TTable Bug...


J. M. Blevins <eaeol...@crosslink.net> wrote in article
<3315a9a2.148412...@news.crosslink.net>...

Quote
> On 26 Feb 97 21:47:19 GMT, "Jacob P.H.Sandin" <ja...@sverige.net>
> wrote:

> >J. M. Blevins <eaeol...@crosslink.net> Wrote
> ><3312fa8f.304...@news.crosslink.net>...
> >> OK, I don't know if this is a known one or not, but...

> >> When I try to filter on two fields by AND - ing them together (ie A=1
> >> AND B>2), as per the TTable documentation, the filtering for the
> >> second field doesn't work.
> >Try
> >(a=1) and (b>2)

> I did try that, actually, and that's what puzzles me. I've tried every

Why not just use OnFilterEvent? I know it is not the solution you are
after, but it works.

Rod.

Re:A TTable Bug...


On 28 Feb 1997 02:29:46 GMT, "Rod Cullison" <RCul...@worldnet.att.net>
wrote:

Quote
>> >> When I try to filter on two fields by AND - ing them together (ie A=1
>> >> AND B>2), as per the TTable documentation, the filtering for the
>> >> second field doesn't work.
>> >Try
>> >(a=1) and (b>2)

>> I did try that, actually, and that's what puzzles me. I've tried every

>Why not just use OnFilterEvent? I know it is not the solution you are
>after, but it works.

I agree, it does work, and is, in fact, how I handled it. It just
sucks that I have to write my own event handler when the documentation
made it look like I was getting out of it... :)

Seriously, though, I'm surprised no one else has seen this. That's
what makes me wonder about my sanity...

TTFN
Mike
J. M. Blevins CACI/IMSS, Inc. I work for cheap, I drink a lot, and I don't sleep.
In other words, I'm a model programmer.

Other Threads