Board index » delphi » Indy: compile error when using indy components

Indy: compile error when using indy components

Hi,

I've just installed Indy 9.0.11. I use Delphi 4.0 Standard, so i also
downloaded the dummy SyncObjs.pas for installation. Problems start when
using Indy components (TIdTCPServer & Client in my case). I'm getting the
following error:

"[Fatal Error]: Unit IdGlobal was compiled with a different version of
SyncObjs.TEvent"

I already tried reinstalling the indy components. Also tried downloading the
SyncObjs.pas file again and following the instrictions from the Indy website
for "If you already have Indy installed" etc.

Any hints? Thanx! Floris Klinkert

 

Re:Indy: compile error when using indy components


"Floris Klinkert" <f.klink...@chello.nl> wrote in
news:3dc51636$2@newsgroups.borland.com:

Quote
> I've just installed Indy 9.0.11. I use Delphi 4.0 Standard, so i also
> downloaded the dummy SyncObjs.pas for installation. Problems start when
> using Indy components (TIdTCPServer & Client in my case). I'm getting the
> following error:

As per the website, Indy 9 no longer supports Delphi 4 standard.

--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
      "Programming is an art form that fights back"

   Need extra help with an Indy problem?

      http://www.atozedsoftware.com/indy/support/

ELKNews - Get your free copy at http://www.atozedsoftware.com

Other Threads