Board index » delphi » Displaying bitmaps in MS Access? (After ADO insert)

Displaying bitmaps in MS Access? (After ADO insert)

I have moved some bitmaps from a mysql server into a microsoft access
database (using param queries)  when I open the mysql table in datasheet
view it displays "long binary data".  when i double click on it i just get
an error message about a problem with the OLE server or ActiveX control.  I
have created a form to display the image and it doesn't -just a blank space
where the picture should go.  I know the image is there becuase the file
size is 280kb and its the only table and their are only 3 records

Your suggestions to get these pictures to display

--
Thanks lots
Paul

 

Re:Displaying bitmaps in MS Access? (After ADO insert)


Access stores its bitmaps as OLE data, with GUIDs and ProgIDs. So, it can
open an OLE field in OLE container, but not just BMP or JPEG. In C++ Builder
or Delphi you should get you image into stream and then display it.

Regards,
Vassiliev V.V.
http://www.oledbdirect.com

"Jez Thompson" <{*word*221}Ducky...@hotmail.com> ???Y/???Y ?????
???Y??: news:3c61bfe0_1@dnews...

Quote
> I have moved some bitmaps from a mysql server into a microsoft access
> database (using param queries)  when I open the mysql table in datasheet
> view it displays "long binary data".  when i double click on it i just get
> an error message about a problem with the OLE server or ActiveX control.
I
> have created a form to display the image and it doesn't -just a blank
space
> where the picture should go.  I know the image is there becuase the file
> size is 280kb and its the only table and their are only 3 records

> Your suggestions to get these pictures to display

> --
> Thanks lots
> Paul

Other Threads