Board index » delphi » help on delphi 1.0 / winsocks - socks.zip (0/1)

help on delphi 1.0 / winsocks - socks.zip (0/1)

 I have to port a rather large application from delphi 2.0 to delphi
1.0. That application involves quite a bit of winsockets stuff. I've
created a component to use that but i get some very strange errors
that i haven't figured out yet. If you extract the files with the
dirs, you'll see that there are three dirs: the library dir contains
dr_socks, wich needs to be installed as a component, and 2 other dirs
implementing simple telnet and ftp thingys. You have to install
dr_socks before you use the 2 other apps, cuz they need it. If you
have any knowledge at all at winsocks or just want to try to find what
i'm doing wrong, plz d/l the file and try this out. It is very
probable that i do a bunch of things the wrong way, since i've never
programmed for 16 bit windows before, so this might be quite simple. I
just don't know.

 Any help at all will be greatly appreciated.

Francis

 

Re:help on delphi 1.0 / winsocks - socks.zip (0/1)


begin 644 Telnet.zip
<uuencoded_portion_removed>
B5"]414Q.150N15A%4$L%!@`````+``L`J`(```G/`0``````
`
end

Re:help on delphi 1.0 / winsocks - socks.zip (0/1)


On 10 Feb 1997 22:49:31 GMT, deric...@cn.ca (Francis De Rico) wrote:

Quote
> I have to port a rather large application from delphi 2.0 to delphi
>1.0. That application involves quite a bit of winsockets stuff. I've
>created a component to use that but i get some very strange errors
>that i haven't figured out yet. If you extract the files with the
>dirs, you'll see that there are three dirs: the library dir contains
>dr_socks, wich needs to be installed as a component, and 2 other dirs
>implementing simple telnet and ftp thingys. You have to install
>dr_socks before you use the 2 other apps, cuz they need it. If you
>have any knowledge at all at winsocks or just want to try to find what
>i'm doing wrong, plz d/l the file and try this out. It is very
>probable that i do a bunch of things the wrong way, since i've never
>programmed for 16 bit windows before, so this might be quite simple. I
>just don't know.

 I have fixed a bunch of small things in my 16 bit app, but i still
have a major problem! The send function doesn't work!!! All the rest
works fine, but not this.

 To use the stuff, extract the files from the attachment, install the
dr_socks component from the library directory and compile the telnet
project. You'll see that everything else works like a charm. So what
am i doing wrong??? I've converted most of the rest of the stuff that
i had to do, so this is one of the last problems left to solve, and
it's a major one, so please help me!!!

Francis

Other Threads