Board index » delphi » "Invalid Enum Value"error in D7 ?!

"Invalid Enum Value"error in D7 ?!

Hi

I started to program a database application using MS Access and ADO .After
building appropriate connection string and trying to connect to database
(at design time, changing 'Connected' property), it returns"Invalid Enum
value" error message, while changing 'Connected' property.Error message
repeats when I attempt Save or Run Project, and after some attempts Object
Inspector grid crashes !!

I am using D7 and am not porting an existing project from older versions of
delphi.

What should I do ?

Thanks

 

Re:"Invalid Enum Value"error in D7 ?!


Quote
>I started to program a database application using MS Access and ADO .After
>building appropriate connection string and trying to connect to database
>(at design time, changing 'Connected' property), it returns"Invalid Enum
>value" error message, while changing 'Connected' property.Error message
>repeats when I attempt Save or Run Project, and after some attempts Object
>Inspector grid crashes !!

I have seen this before in a connection string for JET when values for MODE are
selected that are incompatible.
If that isn't your problem post your connection string.
--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Re:"Invalid Enum Value"error in D7 ?!


Here is my Connection Str :

Provider=Microsoft.Jet.OLEDB.4.0;Data
Source=files/customers.mdb;Mode=ReadWrite|Share Deny None;Persist Security
Info=False;Jet OLEDB:Database Password=phloucce

Should I change anything ?

Thanks

"Brian Bushay TeamB" <BBus...@Nmpls.com> wrote in message
news:n0uqcv45mq2kt4oa8gsum6i5n8a6cremq0@4ax.com...

Quote
> >I started to program a database application using MS Access and ADO
.After
> >building appropriate connection string and trying to connect to database
> >(at design time, changing 'Connected' property), it returns"Invalid Enum
> >value" error message, while changing 'Connected' property.Error message
> >repeats when I attempt Save or Run Project, and after some attempts
Object
> >Inspector grid crashes !!

> I have seen this before in a connection string for JET when values for
MODE are
> selected that are incompatible.
> If that isn't your problem post your connection string.
> --
> Brian Bushay (TeamB)
> Bbus...@NMPLS.com

Re:"Invalid Enum Value"error in D7 ?!


Quote
>Provider=Microsoft.Jet.OLEDB.4.0;Data
>Source=files/customers.mdb;Mode=ReadWrite|Share Deny None;Persist Security
>Info=False;Jet OLEDB:Database Password=phloucce

>Should I change anything ?

Drop the Mode string.  Redwrite and Share Deny None are not compatible
--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Other Threads