Board index » delphi » Bug in porting D2 Memo control to D3?

Bug in porting D2 Memo control to D3?

I have a project that was written in D2, which I'm now updating in
D3.00.  It has a PageControl with several pages, and on most of the
pages there's a read-only Memo control with some help text on it for
the user to read.  

When I try to edit this form, some of the memos lose their Lines
contents, and all my text disappears!  This happens when I make a
change to the form or when I try to open it in the editor, so it looks
like a bug in the code that writes it to the stream.

Is this familiar with anyone?  Is there a workaround?  If not, I'll
work on isolating it and put together a bug report.

Duncan Murdoch

 

Re:Bug in porting D2 Memo control to D3?


A minor followup:  This bug still exists in D3.01, but I haven't been
able to reproduce it reliably.  From something I saw on the Borland
web site, it might have to do with the Lines.Count property of the
TMemo returning a 0 sometimes, possibly in connection with a right
scrollbar, but I don't know what triggers it.

Duncan Murdoch

On Mon, 13 Oct 1997 21:05:08 GMT, dmurd...@pair.com (Duncan Murdoch)
wrote:

Quote
>I have a project that was written in D2, which I'm now updating in
>D3.00.  It has a PageControl with several pages, and on most of the
>pages there's a read-only Memo control with some help text on it for
>the user to read.  

>When I try to edit this form, some of the memos lose their Lines
>contents, and all my text disappears!  This happens when I make a
>change to the form or when I try to open it in the editor, so it looks
>like a bug in the code that writes it to the stream.

>Is this familiar with anyone?  Is there a workaround?  If not, I'll
>work on isolating it and put together a bug report.

>Duncan Murdoch

Other Threads