Board index » delphi » BDE-installation doesn't work anymore

BDE-installation doesn't work anymore

Which registry-keys do I have to manually assaign values to, to make my BDE
5.0 -installation work?

In my old application made with Delphi 3.0 and the install-shield (3.0) that
came with it, I only had to select DLLPath in
(HKEY_LOCAL_MAchine\software\Borland\Database Engine\DLLPATH = <installdir>)
to get BDE to work, since I only use one Paradox-table I do an partial
BDE-installation.

Now when I make the same Install-shield-configuration (Inst.Shield 4.0) and
tries to install a Partial BDE I get an error-message saying : an error
occurred when trying to initialize B..D..E.. bla bla  (error$3E06)
I read here in this forum  that it could be that Bantam.dll was missing but
I have installed it ???

Since I'm not an BDE/Database-expert can anyone tell me exactly what to do
to get my BDE-installation to work.

And an other question, Is it right to install a new BDE-version over the old
one or must I uninstall everything old first (I tried both) because during
the installation it says that it has found another older version but it is
still OK to continue, are there old registry keys that has to be removed
before new ones is written.

kind regards Peter E

 

Re:BDE-installation doesn't work anymore


Quote
>Now when I make the same Install-shield-configuration (Inst.Shield 4.0) and
>tries to install a Partial BDE I get an error-message saying : an error
>occurred when trying to initialize B..D..E.. bla bla  (error$3E06)
>I read here in this forum  that it could be that Bantam.dll was missing but
>I have installed it ???

My advise is do not do a parital install.  Delete any BDE dlls in your current
application directory and then install BDE

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Re:BDE-installation doesn't work anymore


I got the BDE4-BDE5 upgrade to work properly with Installshield Express.

Here is what I did from within InstallShield

1.  Removed the DBE/IDAPI BLL Files Group--As instructed by Inprise
2.  Added Bantan.dll and *.btl to BDE/IDAPI--As instructed by Inprise
3.  Added charset.cvb to BDE/IDAPI--This step was left off the Inprise
instructions.

Mark

Quote
Pex wrote:
> Which registry-keys do I have to manually assaign values to, to make my BDE
> 5.0 -installation work?

> In my old application made with Delphi 3.0 and the install-shield (3.0) that
> came with it, I only had to select DLLPath in
> (HKEY_LOCAL_MAchine\software\Borland\Database Engine\DLLPATH = <installdir>)
> to get BDE to work, since I only use one Paradox-table I do an partial
> BDE-installation.

> Now when I make the same Install-shield-configuration (Inst.Shield 4.0) and
> tries to install a Partial BDE I get an error-message saying : an error
> occurred when trying to initialize B..D..E.. bla bla  (error$3E06)
> I read here in this forum  that it could be that Bantam.dll was missing but
> I have installed it ???

> Since I'm not an BDE/Database-expert can anyone tell me exactly what to do
> to get my BDE-installation to work.

> And an other question, Is it right to install a new BDE-version over the old
> one or must I uninstall everything old first (I tried both) because during
> the installation it says that it has found another older version but it is
> still OK to continue, are there old registry keys that has to be removed
> before new ones is written.

> kind regards Peter E

Other Threads