Board index » delphi » Access Violation upon closing a preview in quick Reports D4

Access Violation upon closing a preview in quick Reports D4

I am experiencing an access violation at address 0000000017 when I attempt
to close the report preview screen.
Using D4 and standard QR.

Any help is appreciated.

Note, the application is a report generator with several reports.  This is
the only unit/form/report that causes an AV.

Thanks

Ken Barker

 

Re:Access Violation upon closing a preview in quick Reports D4


Note to anyone with similar problems:

I was able to alleviate the Access Violations in Quick Reports by doing a
combination of
the following.  I am not sure which one did the trick or if they needed to
be done together....

1.  I removed the suspect unit (report) from my project and substituted a
dummy.  I physically moved the unit, form and dcu to another folder.
I then recompiled the project.

2.  I went to the qusoft site and downloaded their latest update.  QR
standard 3.04.  Ran this application.

3.  Removed the dummy unit from the project and project folder.  Copied the
orginal unit and form (not dcu) back into project folder.  Added the unit to
the project.  Did a build all and voila the access violation is gone (I hope
for good)

Quote
moontan wrote in message <7bn8iu$5...@forums.borland.com>...
>I am experiencing an access violation at address 0000000017 when I attempt
>to close the report preview screen.
>Using D4 and standard QR.

>Any help is appreciated.

>Note, the application is a report generator with several reports.  This is
>the only unit/form/report that causes an AV.

>Thanks

>Ken Barker

Re:Access Violation upon closing a preview in quick Reports D4


I put an 'Application.ProcessMessages' right after every preview and all my
AV's have disappeared.

Other Threads