Board index » delphi » Input Data Not Showing on Reports

Input Data Not Showing on Reports

I have a small network (currently 3 users) using IB6 as the database and my
application is written in D5 using IBX - mainly TIBDatasets for
input/update, and IBQuery for reports etc.
If one user adds a new record and Posts it and another user i.e. runs a
report using IBQuery - the new record is not always visible. It often
remains invisible until the first user logs out completely.  I have set my
Transaction Component to Read Committed.
Have I missed something?  Do I have to force commits or writes or something?
Thanks in advance,
Ian
 

Re:Input Data Not Showing on Reports


Are you commiting after POST ?

--
Sergio Samayoa
Lgica Software
http://www.geocities.com/logicasw/

Re:Input Data Not Showing on Reports


No, can you give me some guidance on where and how?  Could  you possibly
give me an example please.
Thanks for the reply,
 Ian
Quote
"Sergio Samayoa" <serg...@terra.com.gt> wrote in message

news:3b21dac8$1_1@dnews...
Quote
> Are you commiting after POST ?

> --
> Sergio Samayoa
> Lgica Software
> http://www.geocities.com/logicasw/

Re:Input Data Not Showing on Reports


At this moment I haven't time (I'm in a middle of develop process with dead
line next june 13!) and only can said this to you: you must commit any
operation to make available to another users. Try your application adding
next code in AFTER POST event of your dataset:

    IBDatabase1.CommitRetaining;

And you must see the changes in another stations with read commited
transaction isolation.

--
Sergio Samayoa
Lgica Software
http://www.geocities.com/logicasw/

"Ian Grant" <I...@acgrant.freeserve.co.uk> escribi en el mensaje
news:3b224d2e_1@dnews...

Quote
> No, can you give me some guidance on where and how?  Could  you possibly
> give me an example please.
> Thanks for the reply,
>  Ian
> "Sergio Samayoa" <serg...@terra.com.gt> wrote in message
> news:3b21dac8$1_1@dnews...
> > Are you commiting after POST ?

> > --
> > Sergio Samayoa
> > Lgica Software
> > http://www.geocities.com/logicasw/

Re:Input Data Not Showing on Reports


OK, I will try that. I am using IBDatabase, IBTransaction, and IBDataSet for
accessing the data and using the DBNavigator on my Form.
Thanks again for the help,
Ian
Quote
"Sergio Samayoa" <serg...@terra.com.gt> wrote in message

news:3b2262e3_2@dnews...
Quote
> At this moment I haven't time (I'm in a middle of develop process with
dead
> line next june 13!) and only can said this to you: you must commit any
> operation to make available to another users. Try your application adding
> next code in AFTER POST event of your dataset:

>     IBDatabase1.CommitRetaining;

> And you must see the changes in another stations with read commited
> transaction isolation.

> --
> Sergio Samayoa
> Lgica Software
> http://www.geocities.com/logicasw/

> "Ian Grant" <I...@acgrant.freeserve.co.uk> escribi en el mensaje
> news:3b224d2e_1@dnews...
> > No, can you give me some guidance on where and how?  Could  you possibly
> > give me an example please.
> > Thanks for the reply,
> >  Ian
> > "Sergio Samayoa" <serg...@terra.com.gt> wrote in message
> > news:3b21dac8$1_1@dnews...
> > > Are you commiting after POST ?

> > > --
> > > Sergio Samayoa
> > > Lgica Software
> > > http://www.geocities.com/logicasw/

Other Threads