Board index » delphi » Help with Turbo Pascal 7.0

Help with Turbo Pascal 7.0

This is my first post on any newsgroup, so if I break any rules, please tell
me.
I have Turbo Pascal 7.0, and for some reason, whenever I try to load CRT, it
gives me the error: divison by zero. If I run the program a few times, it
will work about 1 out of 10 times. The rest, it gives the error.

I am also new to pascal. Anyone have a clue? (did I just get a bad version?)
Thanx,
Elimis

 

Re:Help with Turbo Pascal 7.0


Do you happen to have a CPU faster than 180 MHz?????
if yes, you need a patch. TP has some error which is corrected then. For
patches, simply look aroun d in  this newsgroup. This question is asked
about once a week...

Markus

Quote
Elimis wrote:
> This is my first post on any newsgroup, so if I break any rules, please tell
> me.
> I have Turbo Pascal 7.0, and for some reason, whenever I try to load CRT, it
> gives me the error: divison by zero. If I run the program a few times, it
> will work about 1 out of 10 times. The rest, it gives the error.

> I am also new to pascal. Anyone have a clue? (did I just get a bad version?)
> Thanx,
> Elimis

Re:Help with Turbo Pascal 7.0


Quote
Elimis wrote:
> This is my first post on any newsgroup, so if I break any rules, please tell
> me.
> I have Turbo Pascal 7.0, and for some reason, whenever I try to load CRT, it
> gives me the error: divison by zero. If I run the program a few times, it
> will work about 1 out of 10 times. The rest, it gives the error.

> I am also new to pascal. Anyone have a clue? (did I just get a bad version?)

You have violated a holy rule but you will be forgiven since this
is your first post. :-)

Before you post to any newsgroup, you should first read the FAQ for
that newsgroup (most groups have one).
FAQ stands for "Frequently Asked Question(s)". A FAQ is a compilation
of the questions which are asked most frequently and their answers.
It can be found here: ftp://garbo.uwasa.fi/pc/link/tsfaqp.zip

The runtime error 200 is THE most frequently asked question ever.
For more information, see http://www.merlyn.demon.co.uk/pas-r200.htm

Re:Help with Turbo Pascal 7.0


JRS:  In article <3A72E86E.4030...@freenet.de>, seen in
news:comp.lang.pascal.borland, Markus Humm <markus.h...@freenet.de>
wrote at Sat, 27 Jan 2001 16:25:34 :-

Quote
>Do you happen to have a CPU faster than 180 MHz?????
>if yes, you need a patch. TP has some error which is corrected then. For
>patches, simply look aroun d in  this newsgroup. This question is asked
>about once a week...
>Elimis wrote:

>> This is my first post on any newsgroup, so if I break any rules, please tell
>> me.
>> I have Turbo Pascal 7.0, and for some reason, whenever I try to load CRT, it
>> gives me the error: divison by zero. If I run the program a few times, it
>> will work about 1 out of 10 times. The rest, it gives the error.

>> I am also new to pascal. Anyone have a clue? (did I just get a bad version?)

I guess that Elimis either has a speed close to, but a little below, 200
MHz Intel-equivalent, or is working on a faster PC within Windows, which
eats a fluctuating amount of performance.

FB has given the solution, but omitted to mention the newsgroup's
mini-FAQ; its auto-poster seems dead, but a current copy is at <URL:
http://www.merlyn.demon.co.uk/clpb-faq.txt>.

For existing failing EXEs, I suggest Andreas Bauer's fixer; for new
programs, Pedt Scragg's Crt unit.

Markus, please learn how to post and find out how to be useful.
Responses should come after quotes, as explained both by Timo himself
(via sig lines 2, 3), and in the mini-FAQ, which you should also read.

The question is asked, and answered, sufficiently often in this
newsgroup that you should be able to indicate exactly where to look for
more information; Timo's FAQ, Pedt's mini-FAQ, for a start, or my own
page.

I suggest that you (and other learners) get a copy of each of those
FAQs, on your computer, and arrange that they are always accessible by a
minimum of clicks - I have links to them at the top of my browser local
home page, but there must be many other ways.

Your header is still broken; it is non-compliant with standards, and the
line "X-Accept-Language: de, de-de, de-ch, de-at, en, en-$€`" cannot be
doing all of whatever it is intended to do.

--
? John Stockton, Surrey, UK.  j...@merlyn.demon.co.uk   Turnpike v4.00   MIME ?
  Prof Timo Salmi's Usenet Q&A <URL:ftp://garbo.uwasa.fi/pc/link/tsfaqn.zip>
  TS FAQs via : http://www.uwasa.fi/~ts/http/ : tsfaq.html  quote margin &c.
No Encoding. Quotes before replies. Snip well. Write clearly. Don't Mail News.

Re:Help with Turbo Pascal 7.0


Dr John Stockton <s...@merlyn.demon.co.uk> schrieb Folgendes:

Quote
> Markus, please learn how to post and find out how to be useful.
> Responses should come after quotes, as explained both by Timo himself
> (via sig lines 2, 3), and in the mini-FAQ, which you should also read.

I thought only Microsoft Outlook Express leads to such broken
postings... but Netscape 6 also does!

--
Nuper erat medicus, nunc est vispillo, Diaulus:
Quod vispillo facit, fecerat et medicus.

Other Threads