Board index » delphi » Index problems with paradox tables and delphi 4

Index problems with paradox tables and delphi 4

Hi All,

I have seen the question posted before, but I didn't understand the answer,
sorry.

Basically, when using Delphi 4 to update my paradox tables, sometimes the
changes don't commit, or the don't commit right away.  FlashBuffers (?) were
mentioned, but I am unfamiliar with how to implement that.

Also, I get a lot of index problems with my tables (perhaps because I have
multiple tables pointing to to the same paradox tables - d'oh!), but I would
like to learn why this is happening and how to avoid it.

Any advice would be GREATLY appreciated :-)

Sincerely,

David Ralphs
da...@davidralphs.com

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

 

Re:Index problems with paradox tables and delphi 4


dbiSaveChanges(qQuery.handle) may be the function you are looking for to
flush the buffers.

Quote
dral...@my-dejanews.com wrote in message

<7dod49$gi...@nnrp1.dejanews.com>...
Quote
>Hi All,

>I have seen the question posted before, but I didn't understand the answer,
>sorry.

>Basically, when using Delphi 4 to update my paradox tables, sometimes the
>changes don't commit, or the don't commit right away.  FlashBuffers (?)
were
>mentioned, but I am unfamiliar with how to implement that.

>Also, I get a lot of index problems with my tables (perhaps because I have
>multiple tables pointing to to the same paradox tables - d'oh!), but I
would
>like to learn why this is happening and how to avoid it.

>Any advice would be GREATLY appreciated :-)

>Sincerely,

>David Ralphs
>da...@davidralphs.com

>-----------== Posted via Deja News, The Discussion Network ==----------
>http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own

Re:Index problems with paradox tables and delphi 4


Look at ___TBDEDataSet.FlushBuffers___ not Flashbuffers
Anders
------------------------------

Quote
dral...@my-dejanews.com wrote:

> Hi All,

> I have seen the question posted before, but I didn't understand the answer,
> sorry.

> Basically, when using Delphi 4 to update my paradox tables, sometimes the
> changes don't commit, or the don't commit right away.  FlashBuffers (?) were
> mentioned, but I am unfamiliar with how to implement that.

> Also, I get a lot of index problems with my tables (perhaps because I have
> multiple tables pointing to to the same paradox tables - d'oh!), but I would
> like to learn why this is happening and how to avoid it.

> Any advice would be GREATLY appreciated :-)

> Sincerely,

> David Ralphs
> da...@davidralphs.com

> -----------== Posted via Deja News, The Discussion Network ==----------
> http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own

--
---------------------------
Anders Johansson
Hadelko AB
Kronobr?nneriet
302 42  Halmstad
Sweden
Tel +46 (0)35 102550
Fax +46 (0)35 187515
e-mail and...@hadelko.se
http://www.hadelko.se
---------------------------

Other Threads