Board index » delphi » EOleSysError - Class not registered - delphi demo simpmail

EOleSysError - Class not registered - delphi demo simpmail

I have a program based on the Delphi Demo found in internet\simpmail.
The program works fine on my machine but when in install it on the
clients machine (I've tried installing with both Wise and
InstallShield) I get the following error message:-

Exceptoin EOleSysError in Module blahblah at 0003FD41
Class not registered.

Would anyone be able to tell me how to solve this, I haven't got a
clue what might be missing.

Thanks, Rob

--------------------------------
email: Rob.Da...@unn.ac.uk
Web:   http://www.unn.ac.uk/~isu8

 

Re:EOleSysError - Class not registered - delphi demo simpmail


Rob,
  My guess is that Module"blahblahblah" holds the answer for you.
                             Good luck!!
-Dave
http://www.erols.com/dparsons
----------------------------------------------------
dpars...@erols.com
-----------------------------------------------------
Quote
Rob Davis wrote in message <366faa31.5289...@news.unn.ac.uk>...
>I have a program based on the Delphi Demo found in internet\simpmail.
>The program works fine on my machine but when in install it on the
>clients machine (I've tried installing with both Wise and
>InstallShield) I get the following error message:-

>Exceptoin EOleSysError in Module blahblah at 0003FD41
>Class not registered.

>Would anyone be able to tell me how to solve this, I haven't got a
>clue what might be missing.

>Thanks, Rob

>--------------------------------
>email: Rob.Da...@unn.ac.uk
>Web:   http://www.unn.ac.uk/~isu8

Re:EOleSysError - Class not registered - delphi demo simpmail


Rob,

In the IDE, click on one of the Internet (POP3 or SMTP) components
and press F1. When the help file opens, go to the Contents tab and
scroll down to the Reference booklet. Open that booklet - the first
item tells you what files you need to include and how to register
the controls on the target machine.

Ken
--
Ken White

Clipper Functions for Delphi
http://members.aol.com/clipfunc

Quote
Rob Davis wrote:

> I have a program based on the Delphi Demo found in internet\simpmail.
> The program works fine on my machine but when in install it on the
> clients machine (I've tried installing with both Wise and
> InstallShield) I get the following error message:-

> Exceptoin EOleSysError in Module blahblah at 0003FD41
> Class not registered.

> Would anyone be able to tell me how to solve this, I haven't got a
> clue what might be missing.

> Thanks, Rob

> --------------------------------
> email: Rob.Da...@unn.ac.uk
> Web:   http://www.unn.ac.uk/~isu8

Other Threads