Board index » delphi » Applyupdates doesn't work with MS SQL Server 2000

Applyupdates doesn't work with MS SQL Server 2000

Hello

I have a C/S application, using Datasnap (Midas) to connect between the
client and the server applications.
The server application is composed of pair of TQuery and TDatasetprovider,
with the query's requestlive=true.
The server is connected to the MS SQL with ODBC alias (sql links gave me
strange exceptions).
Works fine with paradox, but now in SQL Server, when I change a dataset in
the client, and do applyupdates, it fails with no exceptions.
Is there a problem with SQL Server?
How do I find out why the data is not saved?

Thank you in advance

 

Re:Applyupdates doesn't work with MS SQL Server 2000


Solved the problem, seem the clientdataset had tdate field while the server
had it as tdatetime, so it abort save for the entire record.

Quote
"Adi" <adi...@hotmail.com> wrote in message

news:3e4511cb@newsgroups.borland.com...
Quote
> Hello

> I have a C/S application, using Datasnap (Midas) to connect between the
> client and the server applications.
> The server application is composed of pair of TQuery and TDatasetprovider,
> with the query's requestlive=true.
> The server is connected to the MS SQL with ODBC alias (sql links gave me
> strange exceptions).
> Works fine with paradox, but now in SQL Server, when I change a dataset in
> the client, and do applyupdates, it fails with no exceptions.
> Is there a problem with SQL Server?
> How do I find out why the data is not saved?

> Thank you in advance

Other Threads