large varchar fields in ms sql not showing in delphi

Hi everyone,

There's something strange going on with Delphi 4 Enterprise, DBE 5.01.22
and MS SQL 7.0 (the Query Aanalizer mentions 'Version SQL 7.00.623').

I used the Enterprise manager to design the following table:

  Name      Type/Size

 char254   varchar  254
 char255   varchar  255
 char256   varchar  256
 char260   varchar  260
 char1023  varchar 1023
 char1024  varchar 1024
 char1025  varchar 1025
 char1026  varchar 1026
 char4094  varchar 4094
 char4095  varchar 4095
 char4096  varchar 4096
 char4097  varchar 4097
 char5000  varchar 5000
 char7999  varchar 7999
 char8000  varchar 8000
 char2046  varchar 2046
 char2047  varchar 2047
 char2048  varchar 2048
 char2049  varchar 2049
 char2050  varchar 2050
 char62    varchar   62
 char63    varchar   63
 char64    varchar   64
 char65    varchar   65
 char125   varchar  125
 char126   varchar  126
 char127   varchar  127
 char128   varchar  128
 char129   varchar  129
 char130   varchar  130

These are all required fields, default value ''.
I can edit these fields in the Enterprise Manager and in Borland's
SQL explorer.

However, if I use a TTable and TDatasource to link the table to a
DBGrid,
the fields char256, char260, char1024, char2048 and char4096 do not
show up. Neither can I include them in the Fields editor list when I
doubleclick on the TTable. I cannot even acces them with FieldByName(),
this gives a 'Field not found' error.

What is going on here?
Is this a known bug and a fix? OK, I can work around this, the bug
showed
up with a varchar 4096 field, which I can easily change to size 4095,
but how about predictability of the bug with that char260 ?

Thanks in advance for all clues,
Jan

-----------------------------------------------------------------------
Jan Doggen / Masters Software
mass...@xs4all.nl
Leiden, The Netherlands
-----------------------------------------------------------------------