Board index » delphi » Error trying to insert record using BDE on MSSQL 6.5

Error trying to insert record using BDE on MSSQL 6.5

When I try to insert a new record in one of the tables of my MSSQL 6.5
database using BDE version 4.51 I get this error message:

'Non blob column in table required to perform operation.'

No problem occurs if I insert the new record using a MSSQL 6.5 tool.

This table  has an autoincrement field as primary key and it seems that
if I change it to a normal field, the problem doesn't happen.  I NEED
this autoincrement field.

Thank you,

Marcus Martins.

 

Re:Error trying to insert record using BDE on MSSQL 6.5


Some things to try

Get NT4 SP3 Microsoft's Web Site
Get MSSQL SP4 Microsofts web site 5.6 meg
Get BDE5 upgrade 11 meg

Finally it is never a good idea to have an autoincrement field as a
primary key - no you don't need it - you can write a stored procedure
to generate a PK for you

On Fri, 31 Jul 1998 07:43:54 -0300, Marcus Martins

Quote
<marcusvic...@nospam.hotmail.com> wrote:
>When I try to insert a new record in one of the tables of my MSSQL 6.5
>database using BDE version 4.51 I get this error message:

>'Non blob column in table required to perform operation.'

>No problem occurs if I insert the new record using a MSSQL 6.5 tool.

>This table  has an autoincrement field as primary key and it seems that
>if I change it to a normal field, the problem doesn't happen.  I NEED
>this autoincrement field.

>Thank you,

>Marcus Martins.

Other Threads