Board index » delphi » BDE apps slow on some machines, fast on others

BDE apps slow on some machines, fast on others

Just wondering if anyone had any tips on the following ...

We have installed an app. that's written in Delphi and uses BDE.  This
app. runs very quickly on two computers, but on the other two it runs
very, very slowly.

I compared the configurations between the two machines using BDE
Administrator, and noticed that settings were different. For one
thing, under the Configuration tab, under Drivers\Native\Paradox, the
version info on the fast ones is 1.0; the version is 4.0 on the slow
ones.  Some of the other values (block size, level, and lang driver)
were different, two, but I was able to set them to be the same. The
only thing I cannot change is the Version.

I did a file compare betwen the bde directories on a fast workstation
and a slow one, and idapi32.cfg was the only file different. I copied
the quick one to the slow one but still no dice. Also, I notice that
this doesn't change the version.

Any suggestions on what I can do?  How does one change the version?
How is BDE Admin determining the version?  Is there another file
somewhere (such as the system dir) that might be the key to this?

Thanks!

Jen

 

Re:BDE apps slow on some machines, fast on others


Turns out that wasn't it -- it was Norton AntiVirus. Anyone have luck
setting exclusions for it? I tried <dir>\*.* and that didn't work
(where <dir> is the database dir). I think exclusions are kind of
broken in Norton -- I even tried *.* plus subdirs and it still scans
everything. Arg.

Thanks!

Jen

Quote
jen...@colorfulexpressions.com (jennyw) wrote in message <news:327f0ccd.0203271519.5020f7f7@posting.google.com>...
> Just wondering if anyone had any tips on the following ...

> We have installed an app. that's written in Delphi and uses BDE.  This
> app. runs very quickly on two computers, but on the other two it runs
> very, very slowly.

> I compared the configurations between the two machines using BDE
> Administrator, and noticed that settings were different. For one
> thing, under the Configuration tab, under Drivers\Native\Paradox, the
> version info on the fast ones is 1.0; the version is 4.0 on the slow
> ones.  Some of the other values (block size, level, and lang driver)
> were different, two, but I was able to set them to be the same. The
> only thing I cannot change is the Version.

> I did a file compare betwen the bde directories on a fast workstation
> and a slow one, and idapi32.cfg was the only file different. I copied
> the quick one to the slow one but still no dice. Also, I notice that
> this doesn't change the version.

> Any suggestions on what I can do?  How does one change the version?
> How is BDE Admin determining the version?  Is there another file
> somewhere (such as the system dir) that might be the key to this?

> Thanks!

> Jen

Other Threads