Board index » delphi » ms sql server 6.5 speed problems

ms sql server 6.5 speed problems

Hi,

we have a big problem using delphi2 and ms-sql server 6.5
in a network with about 20 users. Sometimes our application
works fine, sometimes it is sooo slow (on the same workstation).
The same application works fine with interbase 4.2.

-we use sql links 3.5

any suggestions ???

 

Re:ms sql server 6.5 speed problems


When is it slow?  Is it slow during database access?  When TTables or
TQueries open?

Quote
Thomas Schweikert <[email protected]> wrote in message

<[email protected]>...
Quote
>Hi,

>we have a big problem using delphi2 and ms-sql server 6.5
>in a network with about 20 users. Sometimes our application
>works fine, sometimes it is sooo slow (on the same workstation).
>The same application works fine with interbase 4.2.

>-we use sql links 3.5

>any suggestions ???

Re:ms sql server 6.5 speed problems


Hi Thomas,

we've got the same problem. The reason (in our case) was the high count of
TTable- and TQuery-Components (no matter if active or not). We solved the
problem by using different TSession-components.

Another reason may be the concurrent access to a database object.

"... When a query requests rows from a table, SQL Server automatically
generates page-level locks. However, if the query requests a large
percentage of the table's rows, then SQL Server escalates the locking from
page level to table level. This process is called lock escalation, and it
makes table scans and operations against a large results set more efficient
because it reduces locking overhead. ..." (stolen from MSDN Library...)

You can display informations about the locks currently held by SQL-Server by
using the stored procedure sp_lock.

Herbert

---
H. Urwer
[email protected]
http://www.usd.de

"The road goes ever on and on ..." (Bilbo Baggins)

Thomas Schweikert <[email protected]> schrieb in Nachricht
<[email protected]>...

Quote
>Hi,

>we have a big problem using delphi2 and ms-sql server 6.5
>in a network with about 20 users. Sometimes our application
>works fine, sometimes it is sooo slow (on the same workstation).
>The same application works fine with interbase 4.2.

>-we use sql links 3.5

>any suggestions ???

Other Threads