Board index » delphi » Client/Server compatibility issues NT4 / Win9x

Client/Server compatibility issues NT4 / Win9x

Hi!

I've made a client/server application that uses the Delphi 5 TClientSocket
and
the TServerSocket components.
When I use the TserverSocket on a NT4(SP6) system and the client (with
TclientSocket)  is a Win9x system everything works fine.

However when I try to use a NT4 (SP6) system as a client it doesn't work. To
be
specific, when the ServerSocket sends a message to the client it doesn't
trigger an OnReadEvent on the client's ClientSocket. The frustrating things
is that it does on a Win9x system.

Are there any known compatibility issues using the client server components
or are there other issues concerning the different OS'es  that I'm not
adressing?

Any help/advice is greatly appreciated.

Thanks,

Jacob

 

Re:Client/Server compatibility issues NT4 / Win9x


Quote
Jacob Schenk <Jacob.Sch...@bpk.nl> wrote in message news:3bde8f17_2@dnews...
> Hi!

> I've made a client/server application that uses the Delphi 5 TClientSocket
> and
> the TServerSocket components.
> When I use the TserverSocket on a NT4(SP6) system and the client (with
> TclientSocket)  is a Win9x system everything works fine.

> However when I try to use a NT4 (SP6) system as a client it doesn't work.
To
> be
> specific, when the ServerSocket sends a message to the client it doesn't
> trigger an OnReadEvent on the client's ClientSocket. The frustrating
things
> is that it does on a Win9x system.

Weird.  Works OK in blocking mode, (NT4-SP5).

Rgds,
Martin

Re:Client/Server compatibility issues NT4 / Win9x


if you use netstat or equivalent on the nt version, does it show the port
open ok?
Ive a couple of applications running approx 8 sockets in non blocking mode
with no problem on a win 2000 machine.

--

Claire Humphrey
Software  Engineer

Quote
"Jacob Schenk" <Jacob.Sch...@bpk.nl> wrote in message

news:3bde8f17_2@dnews...
Quote
> Hi!

> I've made a client/server application that uses the Delphi 5 TClientSocket
> and
> the TServerSocket components.
> When I use the TserverSocket on a NT4(SP6) system and the client (with
> TclientSocket)  is a Win9x system everything works fine.

> However when I try to use a NT4 (SP6) system as a client it doesn't work.
To
> be
> specific, when the ServerSocket sends a message to the client it doesn't
> trigger an OnReadEvent on the client's ClientSocket. The frustrating
things
> is that it does on a Win9x system.

> Are there any known compatibility issues using the client server
components
> or are there other issues concerning the different OS'es  that I'm not
> adressing?

> Any help/advice is greatly appreciated.

> Thanks,

> Jacob

Other Threads