Board index » delphi » Error with RS_RUN in DELPHI 1.0 on WIN95

Error with RS_RUN in DELPHI 1.0 on WIN95

I'm trying to call RS_RUN of Delphi 1.0 From my Application in Windows95.

On my computer it's working ( I Have all the package of Delphi 1.0 and
Delphi 2.0 Install on that computer)

But if i but the program on a other computer It does't work.  All the
ReDIST kit is install (DBE and REPORTSMITH)

The programme is working well until i try to can a report.  When I call
RS_RUN a have " RS_RUN caused a general protection fault"

This is the Detail of the error.  IF someone can help me, it will be
appreciate.

RS_RUN caused a general protection fault
in module BC30RTL.DLL at 0001:0000aadc.
Registers:
EAX=53f70000 CS=2e3f EIP=0000aadc EFLGS=00000202
EBX=00000000 SS=304f ESP=0000528c EBP=00005290
ECX=00000000 DS=2e17 ESI=81600017 FS=0000
EDX=80720000 ES=33af EDI=000000ba GS=0000
Bytes at CS:EIP:
26 8b 5d 02 26 8b 05 26 01 47 0c 26 8b 47 08 2d
Stack dump:
689f02ee ace052a1 00172e3f 001700a9 3e770000

 

Re:Error with RS_RUN in DELPHI 1.0 on WIN95


Alain,

   Make sure that you have not overwritten the OLE files in your WINSYS dir
(c:\windows\system). You should have the WIN 95 OLE files and not the 16
bit OLE.

   For example, I have the following WIN 95 Files on my system (win 95 with
sp1):

compobj.dll
ole2.dll        
ole2.reg        
ole2conv.dll    
ole2disp.dll
ole2nls.dll    
ole2prox.dll    
scp.dll        
stdole.tlb
storage.dll
typelib.dll

which most date from 7/11/95. Try that out.

Other Threads