Board index » delphi » D4: Strange characters in DBASE memo-fields

D4: Strange characters in DBASE memo-fields

Hi,

I am currently working on a port of an old Dbase 5-for-Dos Program to
Windows using Delphi.

Problem: Whenever I open a table that was generated by the DBase 5 program
and that contains memo-fields, Delphi shows strange charactes at the end
of every line of each memo-filed. (charaters look like an "i" with a
strange dot)

I am using TDBMemos do display the DBase-Memofields.

What could be the cause of this ? Is this a known problem ? Am I doing
something wrong ?

thanks for your answers,

        Jochen Tuchbreiter

 

Re:D4: Strange characters in DBASE memo-fields


On 31 Jul 1999 12:42:12 GMT, jochen.tuchbrei...@gsho.de wrote:

Quote
>I am currently working on a port of an old Dbase 5-for-Dos Program to
>Windows using Delphi.

>Problem: Whenever I open a table that was generated by the DBase 5 program
>and that contains memo-fields, Delphi shows strange charactes at the end
>of every line of each memo-filed. (charaters look like an "i" with a
>strange dot)

>I am using TDBMemos do display the DBase-Memofields.

>What could be the cause of this ? Is this a known problem ? Am I doing
>something wrong ?

If I am not mistaken this is a bug in the first release of dBASE 5 for DOS.
Try to get it updated. If you no longer need to use the data files under
the DOS version of dBASE, write a one-time-use Delphi program to iterate
through all the record in the table and delete that arrant character.

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
Steve Koterski         "Television is a medium because anything well done
Felton, CA             is rare."
                                                 -- Fred Allen (1894-1956)

Other Threads