Board index » delphi » Disapearing Error Messages from Server after using Crystal Report 7.0

Disapearing Error Messages from Server after using Crystal Report 7.0

Every time I use "Crystal Reports 7.0" from my Application, error messages
generated either by "raiserror"  in triggers or in stored procedures, stop
attaining my client application. The result is that my Exception Handling
reports to the users a cryptic "General SQL Error", and I lost any
indication of the reason for the exception. Has anybody had similar
behaviors?

We're using:

Delphi C/S 4
SQL Server 6.5
BDE (MSSQL)

thanks,
Harold L. Marzan,
Alexius Santoni
Developer R&D, iSaturno.
asant...@iname.com
isatu...@codetel.net.do
hmarzan_merc...@hotmail.com

 

Re:Disapearing Error Messages from Server after using Crystal Report 7.0


Quote
"Harold L. Marzan" wrote:
> Every time I use "Crystal Reports 7.0" from my Application, error messages
> generated either by "raiserror"  in triggers or in stored procedures, stop
> attaining my client application.

What do you mean by "use Crystal Reports 7.0 from my application"?  Running
the VCL component?  And why are you running a trigger when you're running a
report?  I don't see what you're actually doing.

John Pierce

Re:Disapearing Error Messages from Server after using Crystal Report 7.0


Yes, we use the CR7 VCL component to present reports to users.
The triggers or stored procedures that loose the messages are not related to
the execution of the report;
they are called by the application after viewing the reports of Seagate CR7,
and it is then that we loose the messages.
Had we not visualized a Report we would get the messages. You see it seems
as if there is modifications to the recuperation of
Error Messages from the database server after using CR7.

Do you understand now? Can you help us in any way?

Alexius Santoni
iSaturno.

Quote
John Pierce <jpie...@healthplanning.com> wrote in message

news:397F66D4.C4B6AF0C@healthplanning.com...
Quote

> "Harold L. Marzan" wrote:

> > Every time I use "Crystal Reports 7.0" from my Application, error
messages
> > generated either by "raiserror"  in triggers or in stored procedures,
stop
> > attaining my client application.

> What do you mean by "use Crystal Reports 7.0 from my application"?
Running
> the VCL component?  And why are you running a trigger when you're running
a
> report?  I don't see what you're actually doing.

> John Pierce

Re:Disapearing Error Messages from Server after using Crystal Report 7.0


Alexius,

Yes I do understand.  I've not had anything similar happen.  Do you run
Crystal in its own session?  I use Oracle, run Crystal in its own
session, and have no problems.  Sorry not to be of more help.

John Pierce

Other Threads