Board index » delphi » Delphi 2 Problems: "Getting Started" Project

Delphi 2 Problems: "Getting Started" Project

Quote
Auto-Metrics (dr...@p3.net) wrote:

: I purchased Delphi 2.0 this weekend and brought it home with enthusiasm,
: only to have that enthusiasm dampened by several problems, which I hope
: someone at Borland who reads this group, or another user, can help me
: resolve.

: First problem: "Getting Started" Project -- Global Dive Supply

: The program detailed in the Getting Started manual is not working for me.
: To be specific, the problem is with the Data Module. When I add the
: display grid, as on pp.42-42 of the manual, the grid does _not_ appear to
: be live. That is, when placed on the form, the grid shows only one row and
: one column, and not the customer data as shown in the illustrations on p.
: 43. When I right-click on the DBGrid and select the columns editor, the
: fields are there, and they then appear on the DBGrid, but still no data.

: I repeated the project twice to make sure I followed the instructions
: properly, but the same thing happens. The project runs, of course, but
: still the data doesn't appear.

: Is there a problem with the Data Module CustomerData supplied with Delphi
: 2.0 Developer? Is there something else I need to do to make the link
: "live"?

  I haven't tried it, but a quick look at the instructions doesn't tell
you to set the active property on the Table.
  just a guess,
   Eric

 

Re:Delphi 2 Problems: "Getting Started" Project


Quote
Auto-Metrics wrote:

> I purchased Delphi 2.0 this weekend and brought it home with enthusiasm,
> only to have that enthusiasm dampened by several problems, which I hope
> someone at Borland who reads this group, or another user, can help me
> resolve.

> First problem: "Getting Started" Project -- Global Dive Supply

> The program detailed in the Getting Started manual is not working for me.
> To be specific, the problem is with the Data Module. When I add the
> display grid, as on pp.42-42 of the manual, the grid does _not_ appear to
> be live. That is, when placed on the form, the grid shows only one row and
> one column, and not the customer data as shown in the illustrations on p.
> 43. When I right-click on the DBGrid and select the columns editor, the
> fields are there, and they then appear on the DBGrid, but still no data.

> I repeated the project twice to make sure I followed the instructions
> properly, but the same thing happens. The project runs, of course, but
> still the data doesn't appear.

> Is there a problem with the Data Module CustomerData supplied with Delphi
> 2.0 Developer? Is there something else I need to do to make the link
> "live"?

> ---------------------------------------------------------------------
> David Bozzini                                       Auto-Metrics Ltd.
> ---------------------------------------------------------------------

Make sure you set the active properties of the tables to true and
that you connect the grid to the correct datasource

-Allan

Re:Delphi 2 Problems: "Getting Started" Project


Quote
In article <4hfjtg$...@news.chatlink.com>, ee...@chatlink.com (Eric Edin) wrote:
> : The program detailed in the Getting Started manual is not working for me.
> : To be specific, the problem is with the Data Module. When I add the
> : display grid, as on pp.42-42 of the manual, the grid does _not_ appear to
> : be live. That is, when placed on the form, the grid shows only one row and
> : one column, and not the customer data as shown in the illustrations on p.
> : 43. When I right-click on the DBGrid and select the columns editor, the
> : fields are there, and they then appear on the DBGrid, but still no data.
> : Is there a problem with the Data Module CustomerData supplied with Delphi
> : 2.0 Developer? Is there something else I need to do to make the link
> : "live"?

>   I haven't tried it, but a quick look at the instructions doesn't tell
> you to set the active property on the Table.
>   just a guess,
>    Eric

Thanks, that is precisely right. One needs to open the data module, select
the data table icon in question, and set its "Active" property to True.

Much appreciated.

David

---------------------------------------------------------------------
Auto-Metrics Ltd.
The Import Car Parts Specialists                       (610) 692-9216
---------------------------------------------------------------------

Re:Delphi 2 Problems: "Getting Started" Project


Quote
In article <313B5397.2...@qsd.no>, Allan Lochert <al...@qsd.no> wrote:
> > Is there a problem with the Data Module CustomerData supplied with Delphi
> > 2.0 Developer? Is there something else I need to do to make the link
> > "live"?

> > ---------------------------------------------------------------------
> > David Bozzini                                       Auto-Metrics Ltd.
> > ---------------------------------------------------------------------

> Make sure you set the active properties of the tables to true and
> that you connect the grid to the correct datasource

> -Allan

Thanks, that is precisely right. One needs to open the data module, select
the icons for the tables in question, and set their "Active" properties to
True.

Much appreciated.

David

---------------------------------------------------------------------
Auto-Metrics Ltd.
The Import Car Parts Specialists                       (610) 692-9216
---------------------------------------------------------------------

Other Threads