Board index » delphi » IO Error 103

IO Error 103

I have been encountering a IO error 103 in my application lately. It does
use heavy logging but I have critical sections on all the logging sections.
Does anyone know what could be causing this?
This bug occureed quite often before my critical section but after the cs
it stopped happening. Now it's back. Does anyone know about this? In my
searches for an answer it seems that this happens a lot to delphi developers
does delphi have a problem with AssignFile etc. on win2k?
Thanks,
8an
 

Re:IO Error 103


http://www.efg2.com/Lab/Library/Delphi/IO/IOResult.htm lists a few causes of
I/O error 103.

Quote
"Eytan Heidingsfeld" <ey...@tradertools.com> wrote in message

news:3b94c5a4$1@news.barak.net.il...
Quote
> I have been encountering a IO error 103 in my application lately. It does
> use heavy logging but I have critical sections on all the logging
sections.
> Does anyone know what could be causing this?
> This bug occureed quite often before my critical section but after the cs
> it stopped happening. Now it's back. Does anyone know about this? In my
> searches for an answer it seems that this happens a lot to delphi
developers
> does delphi have a problem with AssignFile etc. on win2k?
> Thanks,
> 8an

Re:IO Error 103


Win2k does only let you open files in Readonly-mode.

Had this problem myself, try this:

Assignfile(....);

filemode := 0;

Reset(...);

Filemode sets Reset into readonly modus, then it works!

Greets,

Christian

Quote
"Eytan Heidingsfeld" <ey...@tradertools.com> wrote in message

news:3b94c5a4$1@news.barak.net.il...
Quote
> I have been encountering a IO error 103 in my application lately. It does
> use heavy logging but I have critical sections on all the logging
sections.
> Does anyone know what could be causing this?
> This bug occureed quite often before my critical section but after the cs
> it stopped happening. Now it's back. Does anyone know about this? In my
> searches for an answer it seems that this happens a lot to delphi
developers
> does delphi have a problem with AssignFile etc. on win2k?
> Thanks,
> 8an

Re:IO Error 103


Hi Eytan,

Quote
>I have been encountering a IO error 103 in my application lately. It does
>use heavy logging but I have critical sections on all the logging sections.
>Does anyone know what could be causing this?

103 = ERROR_TOO_MANY_SEM_REQUESTS

Maybe because of all the critical sections...

Cheers,
   Udo
--
Homepage: http://www.nesshoever.de            No mails please. Reply here.

Delphi env.:                         Global Polio Awareness Campaign 2001+
W2K.sp2, D6Pro & D4Pro.sp3               More info -> http://www.2-mad.com

Other Threads