Problem upading to QR3.04 into D4, and installing QR2.0k into D4

 have installed Delphi 4.0 with update packs 2 and 3.

I have downloaded qr304d4.exe, qr3help.zip and qr20k_4.exe from the
QuickReport web site.

When I try to install any of these 3 I get the message:

  corrupt installation detected

and the installation ceases.

Is this fixable? Anyone else had this problem?

Raymond