Board index » delphi » True / False problem in SQL Server 6.5

True / False problem in SQL Server 6.5

I ran into the same problem when moving from Access to Sybase SQLA and
had to change my SQL code.
Quote
Jibby Joda wrote:

> Hi,

> I have just recently upscaled some paradox tables to SQL Server 6.5 using
> borlands Data Pump tool.

> My problem lies in some statements that read, 'where Finished = True',  the
> thing is that for some reason SQL Server will not take 'True' or 'False'. If
> I change them to '0' or '1' it works fine.

> Am I going to have to change all of my SQL code or can I just add a data
> type somehow?

> Thanks!

 

Re:True / False problem in SQL Server 6.5


Went through the same problem.
Created two constants defined within some conditional compile
declarations so I have some hope for a single set of source.
Then, of course, use 'where Finished = ' + conTrue.
sucks having to recode the SQL property set at design-time.

On Wed, 28 Oct 1998 09:46:28 +1300, "Jibby Joda" <ji...@jibby.com>
wrote:

Quote

>My problem lies in some statements that read, 'where Finished = True',  the
>thing is that for some reason SQL Server will not take 'True' or 'False'. If
>I change them to '0' or '1' it works fine.

Re:True / False problem in SQL Server 6.5


Hi,

I have just recently upscaled some paradox tables to SQL Server 6.5 using
borlands Data Pump tool.

My problem lies in some statements that read, 'where Finished = True',  the
thing is that for some reason SQL Server will not take 'True' or 'False'. If
I change them to '0' or '1' it works fine.

Am I going to have to change all of my SQL code or can I just add a data
type somehow?

Thanks!

Other Threads