Board index » delphi » Problems with OLE DB Provider for ODBC Drivers

Problems with OLE DB Provider for ODBC Drivers

Hi,

I try to connect to a SQL Anywhere Database via ADOExpress and the
abovementioned OLE DB Provider. I use a TADOConnection and a TADODataset
(SELECT * FROM Table).

My Problems are:

1. It's impossible for me to show the data in a TDBGrid. I can't figure out
the right parameters (e.g. CursorType). Most of the time I only get
error-messages (e.g. "Dataset doesn't support bookmarks" or "...BOF or EOF
is true..."). Any suggestions?

2. Instead of Fieldnames I only see a lot of question marks in the
Field-Editor. Is this a bug or also the result of wrong parameters?

Thanks in advance
Frank

 

Re:Problems with OLE DB Provider for ODBC Drivers


Hi all,

I've got a EBF from Sybase. Now it works fine!

Regards
Frank

frsp <frank.spri...@xxx.mummert.de> schrieb in im Newsbeitrag:
837l1m$c...@forums.borland.com...

Quote
> Hi,

> I try to connect to a SQL Anywhere Database via ADOExpress and the
> abovementioned OLE DB Provider. I use a TADOConnection and a TADODataset
> (SELECT * FROM Table).

> My Problems are:

> 1. It's impossible for me to show the data in a TDBGrid. I can't figure
out
> the right parameters (e.g. CursorType). Most of the time I only get
> error-messages (e.g. "Dataset doesn't support bookmarks" or "...BOF or EOF
> is true..."). Any suggestions?

> 2. Instead of Fieldnames I only see a lot of question marks in the
> Field-Editor. Is this a bug or also the result of wrong parameters?

> Thanks in advance
> Frank

Other Threads