Board index » delphi » Re: Howto update Indy?

Re: Howto update Indy?


2008-06-04 05:58:12 PM
delphi185
"mark horrocks" <XXXX@XXXXX.COM>
Quote
Last time I installed Indy 10 after removing Indy 9, I used an installer
from AtoZed. Now I want to update to the latest version of Indy but there
is no automatic installer.
The links to manual install instructions and to the docs page on
www.indyproject.org are broken.
I am clueless and need to get my SSL libraries working asap so I can
deploy
In my experiences,
Indy 9 IdHttp + SSL = work well.
Quote
my project. Any help appreciated.

Mark Horrocks



 
 

Re: Howto update Indy?

"mark horrocks" <XXXX@XXXXX.COM>writes
Quote
The links to manual install instructions and to the docs
page on www.indyproject.org are broken.
They work fine for me. Which links are you referring to exactly?
Quote
I am clueless and need to get my SSL libraries working asap
so I can deploy my project. Any help appreciated.
The latest Indy 10 uses the official OpenSSL libraries from
www.openssl.org.
Gambit
 

Re: Howto update Indy?

Quote
>The links to manual install instructions and to the docs
>page on www.indyproject.org are broken.

They work fine for me. Which links are you referring to exactly?

They did work today. I downloaded the zip and compiled the core, protocols
and system but when i load dclIndyCore70.dpk and hit install I get
"Entry point not found. The procedure entry point
@Idglobal@IndyStrToInt$qqrx17System@AnsiStringi could not be located in the
dydnamic link library IndySystem70.bpl" and then "Error can not load package
C:\Program Files\Delphi7\Projects\Bpl\dclIndyCore70.bpl The specified
procedure could not be found."
The file is in that location with today's timestamp on it. Does anybody know
whats wrong here?
Mark Horrocks
 

Re: Howto update Indy?

"mark horrocks" <XXXX@XXXXX.COM>writes
Quote
They did work today. I downloaded the zip and compiled the core,
protocols and system but when i load dclIndyCore70.dpk and hit
install I get

"Entry point not found. The procedure entry point
<snip>
You did not remove an older Indy installation first.
Gambit
 

Re: Howto update Indy?

Quote
You did not remove an older Indy installation first.

I now have 10.2.3 successfully installed and it successfully loads the SSL
libraries, or at least it stopped complaining about not being able to do so!
Thank you for your assistance, it has been greatly appreciated. Recently I
have developed a service which collects emails from a db and sends them, and
an application that can send and xml packet to a payment gateway and parse
the response.
Mark Horrocks