Board index » delphi » FoxPro index trouble

FoxPro index trouble

We're having some problems using foxpro tables through the BDE and also
through the Visual Foxpro ODBC driver.  When we use the BDE we sometimes
get the error "Table is busy c:\path\file.CDX" even if only one person
is using the database.  Also we have a few records that take a very long
time to come up in our app.  Sometimes reindexing the tables helps,
sometimes it doesn't.  We have been using the VFP ODBC driver (ver
6.00.8440.00) for our queries because BDE foxpro query performance is so
bad.  When we try to use the ODBC driver for tables, half the time it
wont even give you a list of tables, and even if you do the Delphi IDE
doesn't show any of the indexes, which makes it useless to us.  Has
anyone else had these problems?  Has anyone found a solution?  We'd
really appreciate any information that anybody has.

Thanks,

Mike Foster
Sr. Programmer/Analyst
Superior Data Services

 

Re:FoxPro index trouble


after struggling with foxpro indexes for quite awhile, we gave up.  BDE and
foxpro don't support one another very well, especially if you open the files
outside delphi.  we switched to dbase with mdx indexes and after some
surprises ( 100 char limit on index field, unique indexes work like
constraints ), things seem stable enough.
Quote
Michael Foster wrote:
> We're having some problems using foxpro tables through the BDE and also
> through the Visual Foxpro ODBC driver.  When we use the BDE we sometimes
> get the error "Table is busy c:\path\file.CDX" even if only one person
> is using the database.  Also we have a few records that take a very long
> time to come up in our app.  Sometimes reindexing the tables helps,
> sometimes it doesn't.  We have been using the VFP ODBC driver (ver
> 6.00.8440.00) for our queries because BDE foxpro query performance is so
> bad.  When we try to use the ODBC driver for tables, half the time it
> wont even give you a list of tables, and even if you do the Delphi IDE
> doesn't show any of the indexes, which makes it useless to us.  Has
> anyone else had these problems?  Has anyone found a solution?  We'd
> really appreciate any information that anybody has.

> Thanks,

> Mike Foster
> Sr. Programmer/Analyst
> Superior Data Services

Other Threads