Board index » delphi » BGI with NT problem: DOS box FROZEN

BGI with NT problem: DOS box FROZEN

Hello,

I recently bumped into a problem with BGI and NT with a program written in
BP7.

From a text-mode menu I choose a graph wich is display using BGI. The DOS
box switches to full screen and the graph is shown. OK so far. The problem
arises when I press ALT-ENTER to display the graph in a DOS box.  The graph
is shown in a DOS box but the whole program is FROZEN, according to the
title of the DOS box (it shows: MYPROGRAM.EXE  FROZEN)

This doesn't occur in Win95, and I need my graph under NT in a DOS box..

Anybody got a solution for this?

Thanks,
Jan.

 

Re:BGI with NT problem: DOS box FROZEN


Quote
"Jan Broeze" <nos...@nospam.com> wrote:
>Hello,

>I recently bumped into a problem with BGI and NT with a program written in
>BP7.

>From a text-mode menu I choose a graph wich is display using BGI. The DOS
>box switches to full screen and the graph is shown. OK so far. The problem
>arises when I press ALT-ENTER to display the graph in a DOS box.  The graph
>is shown in a DOS box but the whole program is FROZEN, according to the
>title of the DOS box (it shows: MYPROGRAM.EXE  FROZEN)

>This doesn't occur in Win95, and I need my graph under NT in a DOS box..

>Anybody got a solution for this?

Jan,

Unfortunately, there is no solution really for Windows NT. Windows NT
can be a strange beast, freezing up in certain DOS programs at certain
points. This is especially true when using graphics modes in a DOS
virtual session. If you stay in the maximized window you should be ok,
but switching between the two can cause you problems.  Another thing
you may want to do is experiment with another SVGA card and driver
set.  This does have an impact also, at least from my experience.

Mike McWhinney
Chief Engineer
elja, Inc.

Other Threads