Board index » delphi » MAPI problem with MS Mail.

MAPI problem with MS Mail.

Any one experience with MAPI / MS Mail? Does it/does it not work?

My program is a replacement for standard Notepad. Since the first release it
has been MAPI enabled, to send textfiles through e-mail. This works fine when
Eudora or MS-Exchange is the default mail client. But when MS Mail is the
default mail program, there's a problem. My program hangs. It doesn't even give
an error message like it should when sending mail fails (for example when there
is no default mail program). I'm wondering what could cause this, since I
thought MAPI was supposed to work with every mail client that is MAPI capable.
I remember a time ago there was a thread which subject was a bug in MAPI.pas.
Maybe this causes my problem. Could some one repost the fix for this problem.
If I remember well, it had something to do with an upper/lowercase mixture
which wasn't right.

     Rogier Meurs  -  0meur...@lelystad.flnet.nl

        Visit the RogSoft NotePad+ HomePage!
 NotePad+ is the Free Win95 Notepad replacement that
          eats standard Notepad for lunch!
        http://lelystad.flnet.nl/~0meurs01/

 

Re:MAPI problem with MS Mail.


Quote
Rogier Meurs wrote:

> Any one experience with MAPI / MS Mail? Does it/does it not work?

It works. I'm using it.

Quote
> I remember a time ago there was a thread which subject was a bug in MAPI.pas.
> Maybe this causes my problem. Could some one repost the fix for this problem.

The functions MapiLogOn and MapiLogOff should use 'MapiLogon'/'MapiLogoff' in
their calls to GetProcAddress, not 'MapiLogOn'/'MapiLogOff'.
This is fixed in 2.01.

M.

--
Ettertraktet kaffe, er det ekstra god kaffe?

mailto:martin.lars...@delfi-data.msmail.telemax.no
http://www.delfidata.no/users/~martin

Other Threads