Board index » delphi » EOleException - Class not registered

EOleException - Class not registered

i am attempting to deploy a client/server app to a windows 95 pc.. both the
client and server apps will run on the same pc.. the server app accesses an
access db through odbc and can retrieve data... when i run the client app it
starts up the server app but when the frst call to an associated client
dataset is done the apps die with - "EOleException in module PTRACKCLIENT.exe
at 000A09A6  Class not registered".

the apps work fine on the development pc (win 98)!!  as far as i can tell i
have moved/registered the correct dlls (using installshield)..  have also
tried moving/registering other delphi dlls and bpls without success..  can
anyone suggest the solution to this problem...

tia, don blair

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

 

Re:EOleException - Class not registered


If the class is part of an ActiveX or Com componented, has this server been
registered.  You can re-register it using REGSRVR.

MarkM

Re:EOleException - Class not registered


In article <7gpnl8$p8...@pheidippides.axion.bt.co.uk>,
  "Marky" <mark.mam...@syntegra.bt.co.uk> wrote:

Quote
> If the class is part of an ActiveX or Com componented, has this server been
> registered.  You can re-register it using REGSRVR.

> MarkM

originally i registered the server by executing it on the pc... using regedit
i was able to find the two rdm objects that are within the server..  tried
the regsrvr but still get the same error..  any other suggestions??

tia, don

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

Other Threads