Board index » delphi » i'm having trouble using access97 db in d4

i'm having trouble using access97 db in d4

hi,

i'm developing an application for someone that uses a database

i've decided to use access97 to create the db, and set up all the
relations...

but when i try to activate the Ttable for it it says :

  Corrupt index / bad header

how can i fix this???

if i try to access it with the TQuery (SQL) it gives me even more probs

please, help me

 

Re:i'm having trouble using access97 db in d4


Bit more information would help, like which Delphi, which BDE, which DAO,
what version is the Access database,

1) Is the Access DB (DAO) version compatible with the driver you've selected
in the BDE Administrator (I'm assuming you are using the BDE)?
2) If so, have you checked the integrity of the database, ie, does it
compact & repair OK under Access?

Pierre
PS Have a look at http://delphidao.finalfiler.com

Quote
Stephan Johnson <step...@pcmnet.co.za> wrote in message

news:36F362FA.2167C511@pcmnet.co.za...
Quote
> hi,

> i'm developing an application for someone that uses a database

> i've decided to use access97 to create the db, and set up all the
> relations...

> but when i try to activate the Ttable for it it says :

>   Corrupt index / bad header

> how can i fix this???

> if i try to access it with the TQuery (SQL) it gives me even more probs

> please, help me

Re:i'm having trouble using access97 db in d4


Also, check that you have selected MSACCESS as the native driver for your
alias, not STANDARD

Pierre du Parte <pie...@finalfiler.com> wrote in message
news:7cvqjk$cu313@forums.borland.com...

Quote
> Bit more information would help, like which Delphi, which BDE, which DAO,
> what version is the Access database,

> 1) Is the Access DB (DAO) version compatible with the driver you've
selected
> in the BDE Administrator (I'm assuming you are using the BDE)?
> 2) If so, have you checked the integrity of the database, ie, does it
> compact & repair OK under Access?

> Pierre
> PS Have a look at http://delphidao.finalfiler.com

> Stephan Johnson <step...@pcmnet.co.za> wrote in message
> news:36F362FA.2167C511@pcmnet.co.za...
> > hi,

> > i'm developing an application for someone that uses a database

> > i've decided to use access97 to create the db, and set up all the
> > relations...

> > but when i try to activate the Ttable for it it says :

> >   Corrupt index / bad header

> > how can i fix this???

> > if i try to access it with the TQuery (SQL) it gives me even more probs

> > please, help me

Re:i'm having trouble using access97 db in d4


Are you using the native Access driver or ODBC?

If you are using the native driver, have you changed the DLL setting for the
MSACCESS in BDE Administrator to IDDA3532.DLL?

Is DAO 3.5 installed on the system?

Have you created an alias to the MDB file that specifies MSACCESS as the
driver?

Bill

--

Bill Todd - TeamB
(TeamB cannot respond to email questions. To contact me
 for any other reason remove nospam from my address.)

Re:i'm having trouble using access97 db in d4


Hello,

If I use Delphi 4, DAO 3.5, how can I access Ms-Access 97 in Delphi without
using BDE and ODBC ???

Would you please to give me a simple example ?

BEst regards,
Eric

Quote
Pierre du Parte wrote:
> Bit more information would help, like which Delphi, which BDE, which DAO,
> what version is the Access database,

> 1) Is the Access DB (DAO) version compatible with the driver you've selected
> in the BDE Administrator (I'm assuming you are using the BDE)?
> 2) If so, have you checked the integrity of the database, ie, does it
> compact & repair OK under Access?

> Pierre
> PS Have a look at http://delphidao.finalfiler.com

> Stephan Johnson <step...@pcmnet.co.za> wrote in message
> news:36F362FA.2167C511@pcmnet.co.za...
> > hi,

> > i'm developing an application for someone that uses a database

> > i've decided to use access97 to create the db, and set up all the
> > relations...

> > but when i try to activate the Ttable for it it says :

> >   Corrupt index / bad header

> > how can i fix this???

> > if i try to access it with the TQuery (SQL) it gives me even more probs

> > please, help me

--
     _                                                  _
    / ) |~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~| ( \
   / /  |                                            |  \ \
 _( /_  | _   Chow Hoi Ka, Eric                    _ |  _) )_
(((\ \> |/ )                                      ( \| </ /)))
(\\\\ \_/ /   E-Mail : d951...@sftw.umac.mo        \ \_/ ////)
 \       /                                          \        /
  \    _/     http://www.sftw.umac.mo/~d951686/      \_     /
  /   / |____________________________________________| \    \
 /   /                                                   \    \

Other Threads