Board index » delphi » Apps using BDE (using Paradox) slow to start on two new machines

Apps using BDE (using Paradox) slow to start on two new machines

Two different apps, Goldmine, and a custom application have been running fine on a network for a number of years.  Data is on a server.

The networking performance of the affected workstations is normal, and files can be copied from the networked path at identical speeds for the affected and non-affected machines.

The Paradox driver version for the new machines was both version 4, and most of the unaffected machines are using driver version 1.  However, one of the unaffected machines is also running version 4.

I did notice that on the affected machine running windows 2000, that when started the application grew from its original size by several megabytes, to 10MB.  The unaffected machines start instantly.

I checked the configuration on all machines involved and everything looks identical.  I suspect that caching is happening differently on these machines versus the others, but can't see where the configuration might be different, and can't tell this definitively.

Any thoughts or assistance in this matter would be gratefully received.

Cordially,

Justin Thomas
GCDi

just...@nospam.gcdi.com
(remove the nospam. if you wish to send email)

 

Re:Apps using BDE (using Paradox) slow to start on two new machines


What BDE version? What OS for the workstations? What
network server?

Quote
"Justin Thomas" <just...@nospam-remove.gcdi.com> wrote:
>the application grew from its original size by several
>megabytes, to 10MB.

Whoa!  Just what are you saying? Your .exe file grew in size?
The table grew in size? Or what???

What virus checking software is on the new machines?
Is it checking against every file opened?

Rick Carter
Rick.Car...@cincww.rcc.org
Chair, Paradox/Delphi SIG, Cincinnati PC Users Group

Re:Apps using BDE (using Paradox) slow to start on two new machines


Quote
"Rick Carter" <Rick.Car...@cincww.rcc.org> wrote:

>What BDE version? What OS for the workstations? What
>network server?

BDE Version 5.01

A mixture of 98 and 2000 professional machines.  The two machines with issues are 98 and 2000.  There are 4 machines with no issues, running 98.  The 'server' is running 2000 professional.

Quote

>"Justin Thomas" <just...@nospam-remove.gcdi.com> wrote:
>>the application grew from its original size by several
>>megabytes, to 10MB.

>Whoa!  Just what are you saying? Your .exe file grew in size?
>The table grew in size? Or what???

In task manager, yes, the application using the BDE grew in size, up in small and large steps.

Quote
>What virus checking software is on the new machines?
>Is it checking against every file opened?

Norton AV 2001 is running on all machines.  Every virus scanner has the same configuration (live scanning, all files.)

Quote
>Rick Carter
>Rick.Car...@cincww.rcc.org
>Chair, Paradox/Delphi SIG, Cincinnati PC Users Group

Thank you for looking at the issue

Cordially,

Justin Thomas
GCDi
just...@nospam.gcdi.com

Re:Apps using BDE (using Paradox) slow to start on two new machines


Quote
"Justin Thomas" <just...@nospam.gcdi.com> wrote:
>Norton AV 2001 is running on all machines.  Every virus
>scanner has the same configuration (live scanning, all files.)

Well, that can be a big performance hit for a database program.
You might want to consider excluding the tables and indexes from
scanning.

Other than that, I'm not sure what to suggest.  You can look
around at http://www.borland.com/devsupport/bde/ and
http://www.bdesupport.com/ for more ideas.

Rick Carter
Rick.Car...@cincww.rcc.org
Chair, Paradox/Delphi SIG, Cincinnati PC Users Group

Other Threads