problem with oracle database and odbc-driver

Ive got problems with an oracle database v8, v7 and the odbc-driver.

Which ODBC-driver do I have to use, if an application should run on
oracle database v8.1.5 and also on oracle database v7.3?
Until now I get an error message, if I work with the application, that
was developed with Delphi 3!I receive the message only when I work with
the 8.1.5 database!

Im grateful for each proposal!!