Board index » delphi » Memo field gets edbEngineError - Non-blob column in table required to perform operation

Memo field gets edbEngineError - Non-blob column in table required to perform operation

When inserting a new record and trying to post the record,  I get the error
only if I put a value in my Memo field.
edbEngineError - Non-blob column in table required to perform operation
If the record exist and I edit the field, then post, I get no Error.
Using D5, Access 2000 via ODBC, IP2000.20, BDE version 5.1.1.1(11-12-99)
The edit control is tdbMemo (also tried eedbedit with no change in results)
IF I set AutoDisplay to False the Error does not occur but My users want to
see that data field without clicking on it.
 

Re:Memo field gets edbEngineError - Non-blob column in table required to perform operation


My key is an autoinc field(NUM) but the AutoRefresh of the table is false
becuase when true the Post event gives me record\key delete error and will
not save record.
The field(NUM) property AutoGenerate makes no difference is anything I do.

Quote
"leapin" <wa...@resa.net> wrote in message news:3ba7798c$1_1@dnews...
> When inserting a new record and trying to post the record,  I get the
error
> only if I put a value in my Memo field.
> edbEngineError - Non-blob column in table required to perform operation
> If the record exist and I edit the field, then post, I get no Error.
> Using D5, Access 2000 via ODBC, IP2000.20, BDE version 5.1.1.1(11-12-99)
> The edit control is tdbMemo (also tried eedbedit with no change in
results)
> IF I set AutoDisplay to False the Error does not occur but My users want
to
> see that data field without clicking on it.

Other Threads