Board index » delphi » D5 and TDBGrid (Please TEAMB!) (re-re-post)

D5 and TDBGrid (Please TEAMB!) (re-re-post)

I have just installed Delphi 5 Enterprise edition, and I have rebuild my
application.

I have a form with TDBGrid component, linked to TQuery component. I have
arranged the TDBGridColumns (color, font) with the TColumn editor. The
TQuery object is Active=False.
I have a button in the form that open the TQuery object.

In design mode the width of TDBGridColumns is Ok.

When I run the application, the size of TDBGridColumns is not the same
that appear in design mode.
If I open a TQuery object in design mode, when I run the application the
size of TDBGridColumns is OK.

My application run ok with Delphi 4 Client-Server.

Is this a bug in Delphi or am I doing something wrong?

Thanx in advance,
Stefano

 

Re:D5 and TDBGrid (Please TEAMB!) (re-re-post)


Quote
In article <3847A378.1513D...@tin.it>, Prazzoli Stefano wrote:
> When I run the application, the size of TDBGridColumns is not the same
> that appear in design mode.
> If I open a TQuery object in design mode, when I run the application the
> size of TDBGridColumns is OK.

You don't say how they are different.

I would view the form as text with and without the TQuery open to see how
the saved column properties differ. I know that there was a problem with
the streaming of column widths if they were a certain size.

 Mike Orriss (TeamB)
 (Unless stated otherwise, my replies relate to Delphi 4.03/5.00)
 (Unsolicited e-mail replies will most likely be ignored)

Other Threads