Board index » delphi » Delphi 5 Pro and Windows 2000 Professional

Delphi 5 Pro and Windows 2000 Professional

I am trying to install Delphi 5 Pro onto a new machine running Windows 2000
Professional. During installation, vcf132.ocx, vcfi32.ocx, and vspell.ocx
fail to auto-register. After installation, I get a runtime error 216 during
bootup and when I try to go into the control panel. Installation was done
logged on as Administrator.

How do I cure these errors?

--
Alton Newman
Coprocess SA
1, rue Piachaud
1204 Geneva, Switzerland

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.286 / Virus Database: 152 - Release Date: 09/10/2001

 

Re:Delphi 5 Pro and Windows 2000 Professional


Hi,

Make sure all background running software is turned off, i.e. Virus checkers,
etc.  You may also want to turn your hardware acceleration down to none.  Then
run D6regclean from the bin directory, and from the D6 disk, run the repair
option.  This should clear things up, if not repost.
--
Regards,
Kendall

Please visit our online support pages at
http://www.borland.com/devsupport/

===========================================================
 Kendall Sullivan (Borland)
 Contract Support                              800 353-2211
 Incident Support                              888 683-2378
 Borland                            http://www.borland.com/
 Newsgroups       http://www.borland.com/newsgroups/#delphi
===========================================================

Re:Delphi 5 Pro and Windows 2000 Professional


Thanks Kendall, I will try that tomorrow when I get into work.

A coworker has basically the same installation with Win2000, however, Delphi
was installed under Win98 and later upgraded to Win2000.

The machine is a Dell P4/1.6GHz, 512MB RAM, 40GB. As it stands, this is what
I know at this time:

1) Virus checkers are turned off, although there are some other programs
running in the background. I will turn them off on future attemps.

2) This is a new machine that came with W2000 Pro installed. I have
downloaded and applied all available Windows 200 Professional patches,
fixes, and service releases.

3) Towards the end of the Delphi 5 Pro (not 6) installation, I get a "failed
to register" error for vcf132.ocx, vcfi32.ocx, and vspell32.ocx.

4) After installing Delphi 5 Pro, Delphi would NOT run giving some VCL/DLL
error (I don't remember exactly which one).

5) While rebooting, I received a runtime 216 error @0002AD0. I also get the
same error when opening the Control Panel. It only happens when opening the
CP the 1st and 2nd time, the 3rd and subsequent times I do NOT get the
error. I tracked this error to BDEADMIN.CPL.  After applying the 25MB patch,
Delphi will run seemingly properly.

6) The first time Delphi is run, it gives a message about a de{*word*81} not
pointing to Delphi and asks if I want it to be changed. I answer Yes, and no
longer get the message.

7) After installing my 3rd party components, Delphi runs and compiles. EXEs
run fine as stand-alones, however, if I try to run them under the Delphi IDE
(F9) the system hangs with an "address violation @ address 080D75FE in
module BORDBK50.DLL, write of address 3BE6A259".

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.281 / Virus Database: 149 - Release Date: 9/18/01

Re:Delphi 5 Pro and Windows 2000 Professional


Hi,

Did Delphi 5 run before you installed all the third party components?

--
Regards,
Kendall

Please visit our online support pages at
http://www.borland.com/devsupport/

===========================================================
 Kendall Sullivan (Borland)
 Contract Support                              800 353-2211
 Incident Support                              888 683-2378
 Borland                            http://www.borland.com/
 Newsgroups       http://www.borland.com/newsgroups/#delphi
===========================================================

Re:Delphi 5 Pro and Windows 2000 Professional


<<
4) After installing Delphi 5 Pro, Delphi would NOT run giving some VCL/DLL
error (I don't remember exactly which one).

5) While rebooting, I received a runtime 216 error @0002AD0. I also get the
same error when opening the Control Panel. It only happens when opening the
CP the 1st and 2nd time, the 3rd and subsequent times I do NOT get the
error. I tracked this error to BDEADMIN.CPL.  After applying the 25MB patch,
Delphi will run seemingly properly.

7) After installing my 3rd party components, Delphi runs and compiles. EXEs
run fine as stand-alones, however, if I try to run them under the Delphi IDE
(F9) the system hangs with an "address violation @ address 080D75FE in
module BORDBK50.DLL, write of address 3BE6A259".

Quote

Hi again Kendall,
Delphi not running in #4 was prior to adding the 3rd party components, since
Delphi would not run. After appying the 25MB patch (#5), Delphi would
run/startup, however I have no programs to compile that do not use any of
the 3rd party stuff (I guess I could write something).  Since I did not
attempt a compile/run (F9) prior to adding the components, at this point it
was after adding them that I had the problem with the access violation of
BORDBK50.DLL.

I managed to disable the bdeadmin.cpl using TweakUI and thus avoided the rt
216 error (although it may had other repercussions). I use Apollo and do not
use the BDE anyway.

Alton

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.281 / Virus Database: 149 - Release Date: 9/19/01

Re:Delphi 5 Pro and Windows 2000 Professional


My system: Dell Dimension 8200, P4/1.6GHz, 512MB RAM, 40GB HD, 32MB NVIDIA
GeForce2 MX (with TV Out) video card
-----------------------
Delphi 5 Professional Setup:
Type of setup - Typical
Install Interbase Client - deselected
-----------------------
Latest results:
During original installation I get the following message in "Setup is
configuring your system","Processing self registering files":
The following self registering DLL's faled to register:
C:\WINNT\System32\vcf132.ocx;C:\WINNT\System32\vcfi32.ocx;C:\WINNT\System32\
vspell32.ocx

Upon initial reboot following installation error occurred (which is
bdeadmin.cpl):
Error: Runtime error 216 @ 00002D2C

Upon attempting to run Delphi, I get the following error and Delphi will not
run:
delphi32.exe - Entry Point Not Found
The procedure entry point ringd could not be located in the dynamic link
library Vcl50.bpl

Applied the Delphi 5 Professional update patch (25MB) with no problems.
Added no 3rd part components. Delphi starts with no apparent problems,
however, attempting to compile and run (F9) any program, or even just an
empty project will halt the system with the following error:
Access violation at address 040775FE in module 'bordbk50.dll'. Write of
address 3BE693C8.

Turning off integrated debugging in Delphi avoids the access violation, but
then of course there is no integrated debugging.
-----------------------
I have seen posting via Google about problems using the Delphi De{*word*81} with
NVIDIA cards. My system has a 32MB NVIDIA GeForce2 MX (with TV Out) video
card. I have updated the driver to version 1.4.6.5, reduced resolution,
reduced and turned off hardware acceleration, and even removed the
NvCplDaemon from the registry's
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run, but
nothing changes.

So as it stands, from the Delphi Help screen I have Delphi Professional
Version 5.0 (Build 6.18) Update Pack 1 and Windows 2000 (Build 2195: Service
Pack 2) - but no integrated debugging!

Alton

Other Threads