Board index » delphi » EDBEngineError "Invalid file name"

EDBEngineError "Invalid file name"

I got the message 'EDBEngineError with message "Invalid file name"'
while I run my program. My program is using Paradox on the Netware
5 file server. Client is using Windows98. The program is write by Delphi 4
C/S Edition. I also tried to install the lastest DBE on the client. However,
the error message remain appear.

Please Help!!!

Thanks & Best Regards,
Forrest Lo.

 

Re:EDBEngineError "Invalid file name"


Yes.

Quote
Chris Roberts <croberts_nils...@picknowl.com.au> wrote in message

news:3765dc64.81941244@forums.inprise.com...
Quote
> "Forrest Lo" <forr...@netvigator.com> wrote:

> >I got the message 'EDBEngineError with message "Invalid file name"'
> >while I run my program. My program is using Paradox on the Netware
> >5 file server. Client is using Windows98. The program is write by Delphi
4
> >C/S Edition. I also tried to install the lastest DBE on the client.
However,
> >the error message remain appear.

> Do you have OS2 / long filename support enabled on the server?

> Regards,
> Chris Roberts

Re:EDBEngineError "Invalid file name"


Quote
"Forrest Lo" <forr...@netvigator.com> wrote:
>I got the message 'EDBEngineError with message "Invalid file name"'
>while I run my program. My program is using Paradox on the Netware
>5 file server. Client is using Windows98. The program is write by Delphi 4
>C/S Edition. I also tried to install the lastest DBE on the client. However,
>the error message remain appear.

Do you have OS2 / long filename support enabled on the server?

Regards,
Chris Roberts

Re:EDBEngineError "Invalid file name"


Quote
Forrest Lo wrote in message <7k4a2v$j3...@forums.borland.com>...
>I got the message 'EDBEngineError with message "Invalid file name"'
>while I run my program. My program is using Paradox on the Netware
>5 file server. Client is using Windows98. The program is write by Delphi 4
>C/S Edition. I also tried to install the lastest DBE on the client.
However,
>the error message remain appear.

Try changing any BDE aliases you are using so that there are no spaces in
them.
For example change c:\program files\stuff to c:\progra~1\stuff
This was a problem with some versions of the BDE but should have been fixed
with BDE 5.01.

Re:EDBEngineError "Invalid file name"


Thank You very much!
My problem is solved.

Quote
Damian Tarnawsky <dam...@aljan.com.au> wrote in message

news:7k5b9d$k9o1@forums.borland.com...
Quote

> Forrest Lo wrote in message <7k4a2v$j3...@forums.borland.com>...
> >I got the message 'EDBEngineError with message "Invalid file name"'
> >while I run my program. My program is using Paradox on the Netware
> >5 file server. Client is using Windows98. The program is write by Delphi
4
> >C/S Edition. I also tried to install the lastest DBE on the client.
> However,
> >the error message remain appear.

> Try changing any BDE aliases you are using so that there are no spaces in
> them.
> For example change c:\program files\stuff to c:\progra~1\stuff
> This was a problem with some versions of the BDE but should have been
fixed
> with BDE 5.01.

Other Threads